summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-09-09 16:38:22 -0400
committerLeo Famulari <leo@famulari.name>2018-09-09 18:52:04 -0400
commitd4bd2453ec6c2342d071cb9a9708280cf45b23ca (patch)
tree487eb3d9fab1f12f9dea2d67448ddc9a3334ede0 /gnu/packages/tls.scm
parentced98c7e89a22c551dd23acd7a1b4f861958d876 (diff)
gnu: certbot: Update to 0.27.1.
* gnu/packages/tls.scm (python-acme): Update to 0.27.1. [arguments]: Use invoke. (certbot): Update to 0.27.1. [native-inputs]: Use python-sphinx-1.6.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index e42b6dfc6c..5e49509ddd 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -518,20 +518,20 @@ netcat implementation that supports TLS.")
(package
(name "python-acme")
;; Remember to update the hash of certbot when updating python-acme.
- (version "0.26.1")
+ (version "0.27.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "acme" version))
(sha256
(base32
- "1glhwqj6yyb11820lspgd0gl5dqdfljn43kcy4ar5caccpsbbrw6"))))
+ "142gynlfx7yv0sdba3gpdxlnhg9chhz7hpdxdrp630z17h1bk9ri"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(add-after 'build 'build-documentation
(lambda _
- (zero? (system* "make" "-C" "docs" "man" "info"))))
+ (invoke "make" "-C" "docs" "man" "info")))
(add-after 'install 'install-documentation
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -575,7 +575,7 @@ netcat implementation that supports TLS.")
(uri (pypi-uri name version))
(sha256
(base32
- "0rnayqhdabm0rljxh76blqd11h51dqnwlwvql0j6xwzpccym30s9"))))
+ "0anh3vjy9sif1bkp25nj76ii37xx8hh0igcx60ppag12xlabsw1m"))))
(build-system python-build-system)
(arguments
`(,@(substitute-keyword-arguments (package-arguments python-acme)
@@ -596,7 +596,7 @@ netcat implementation that supports TLS.")
`(("python-nose" ,python-nose)
("python-mock" ,python-mock)
;; For documentation
- ("python-sphinx" ,python-sphinx)
+ ("python-sphinx" ,python-sphinx-1.6)
("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)
("python-sphinx-repoze-autointerface" ,python-sphinx-repoze-autointerface)
("python-sphinxcontrib-programoutput" ,python-sphinxcontrib-programoutput)