summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-02-07 21:53:55 +0100
committerLeo Famulari <leo@famulari.name>2023-02-11 23:17:31 +0100
commitf844deb7acfb45f3b2f5a18cde5c662fc5ba0f6d (patch)
treea4e268cc3f816b86215aee2f95d38f0af98324c5 /gnu/packages/tls.scm
parentdf163df8307ab91b14d67b074bac35464afa6bdb (diff)
gnu: OpenSSL 3: Update to 3.0.8 [security fixes].
Fixes CVE-2023-0215, CVE-2023-0216, CVE-2023-0217, CVE-2023-0286, CVE-2023-0401, CVE-2022-4203, CVE-2022-4304, and CVE-2022-4450. https://www.openssl.org/news/secadv/20230207.txt gnu/packages/tls.scm (openssl-3.0): Update to 3.0.8.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 66c111cb56..9eaa859a57 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -636,7 +636,7 @@ OpenSSL for TARGET."
(define-public openssl-3.0
(package
(inherit openssl-1.1)
- (version "3.0.7")
+ (version "3.0.8")
(source (origin
(method url-fetch)
(uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -649,7 +649,7 @@ OpenSSL for TARGET."
(patches (search-patches "openssl-3.0-c-rehash-in.patch"))
(sha256
(base32
- "0virbkcrw7nn3gr5r51z722gs1ppig0casj0c9pnj3i65829s143"))))
+ "0gjb7qjl2jnzs1liz3rrccrddxbk6q3lg8z27jn1xwzx72zx44vc"))))
(arguments
(substitute-keyword-arguments (package-arguments openssl-1.1)
((#:phases phases '%standard-phases)