summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-04-22 17:28:17 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-02 15:14:43 +0200
commitaf856afb6cb91f0ea717d333bc622c9b5a1af1be (patch)
tree3c37ccaec0de6655cf31ca0dc04075562aea8b32 /gnu/packages/tls.scm
parenta5a408c3a7d4382e2e24ee5f2c5c48dbcc7cecdf (diff)
gnu: s2n: Link to aws-lc as libcrypto dependency.
* gnu/packages/tls.scm (s2n): [arguments]: Fix for openssl as replacement input for aws-lc. [propagated-inputs]: Add aws-lc and remove openssl. [supported-systems]: Only support x86_64-linux. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 54921fdc86..84ed0caa5d 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -1130,7 +1130,7 @@ derived from Mozilla's collection.")
(define-public s2n
(package
(name "s2n")
- ; Update only when updating aws-crt-cpp.
+ ;; Update only when updating aws-crt-cpp.
(version "1.3.10")
(source (origin
(method git-fetch)
@@ -1144,10 +1144,13 @@ derived from Mozilla's collection.")
(build-system cmake-build-system)
(arguments
'(#:configure-flags
- '("-DBUILD_SHARED_LIBS=ON")))
- (propagated-inputs
- `(("openssl" ,openssl)
- ("openssl:static" ,openssl "static")))
+ '("-DBUILD_SHARED_LIBS=ON"
+ ;; Remove in next update; see https://github.com/aws/s2n-tls/pull/3108
+ ;; Building with 'Werror' results in compilation error (even building
+ ;; with gcc) when replacing the aws-lc input with openssl.
+ "-DUNSAFE_TREAT_WARNINGS_AS_ERRORS=OFF")))
+ (propagated-inputs (list aws-lc))
+ (supported-systems '("x86_64-linux"))
(synopsis "SSL/TLS implementation in C99")
(description
"This library provides a C99 implementation of SSL/TLS. It is designed to