summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-11-02 22:26:35 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-11-02 22:26:35 +0100
commitbdf0b6fcfff004bba0abf9584b870b53fa13f005 (patch)
tree9acfc11f9b43bf257fe0dcefd5f28e558b058e37 /gnu/packages/tls.scm
parentb4c22f25468cbb0b1644194381b25c795502bc16 (diff)
gnu: openssl: Remove graft for 1.0.2m.
* gnu/packages/tls.scm (openssl): Update to 1.0.2m. [source]: Add HTTPS mirror. (openssl-1.0.2m): Remove variable.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm28
1 files changed, 5 insertions, 23 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index fcd012d894..98ea8729d4 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -237,18 +237,19 @@ required structures.")
(define-public openssl
(package
(name "openssl")
- (version "1.0.2l")
- (replacement openssl-1.0.2m)
+ (version "1.0.2m")
(source (origin
(method url-fetch)
- (uri (list (string-append "ftp://ftp.openssl.org/source/"
+ (uri (list (string-append "https://www.openssl.org/source/openssl-"
+ version ".tar.gz")
+ (string-append "ftp://ftp.openssl.org/source/"
name "-" version ".tar.gz")
(string-append "ftp://ftp.openssl.org/source/old/"
(string-trim-right version char-set:letter)
"/" name "-" version ".tar.gz")))
(sha256
(base32
- "037kvpisc6qh5dkppcwbm5bg2q800xh2hma3vghz8xcycmdij1yf"))
+ "03vvlfnxx4lhxc83ikfdl6jqph4h52y7lb7li03va6dkqrgg2vwc"))
(snippet
'(begin
;; Remove ELF files. 'substitute*' can't read them.
@@ -381,25 +382,6 @@ required structures.")
(license license:openssl)
(home-page "http://www.openssl.org/")))
-;; Fixes CVE-2017-3735 and CVE-2017-3736.
-;; See <https://www.openssl.org/news/cl102.txt>.
-(define-public openssl-1.0.2m
- (package
- (inherit openssl)
- (version "1.0.2m")
- (source (origin
- (inherit (package-source openssl))
- (uri (list (string-append "https://www.openssl.org/source/openssl-"
- version ".tar.gz")
- (string-append "ftp://ftp.openssl.org/source/openssl-"
- version ".tar.gz")
- (string-append "ftp://ftp.openssl.org/source/old/"
- (string-trim-right version char-set:letter)
- "/openssl-" version ".tar.gz")))
- (sha256
- (base32
- "03vvlfnxx4lhxc83ikfdl6jqph4h52y7lb7li03va6dkqrgg2vwc"))))))
-
(define-public openssl-next
(package
(inherit openssl)