summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-05-15 19:55:16 -0400
committerLeo Famulari <leo@famulari.name>2016-05-16 14:52:34 -0400
commit1d30d554b5389eb53eaa1ef7efb07772d0383510 (patch)
treea244b8ce772dc400d41ab6ab842dd4c03c5b241a /gnu/packages/tls.scm
parent549f95128352ec72ba722ea4f634b6ae32f8a1d4 (diff)
gnu: openssl: Update to 1.0.2h.
* gnu/packages/tls.scm (openssl): Update to 1.0.2h. [replacement]: Remove field. (openssl/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm24
1 files changed, 2 insertions, 22 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index e61428510a..92c1263808 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -197,8 +197,7 @@ required structures.")
(define-public openssl
(package
(name "openssl")
- (version "1.0.2g")
- (replacement openssl/fixed)
+ (version "1.0.2h")
(source (origin
(method url-fetch)
(uri (list (string-append "ftp://ftp.openssl.org/source/"
@@ -208,7 +207,7 @@ required structures.")
"/" name "-" version ".tar.gz")))
(sha256
(base32
- "0cxajjayi859czi545ddafi24m9nwsnjsw4q82zrmqvwj2rv315p"))
+ "06996ds1rk8xhnyb5y273a7xkcxhggp4bq1g02rab55d7bjhfh0x"))
(patches (search-patches "openssl-runpath.patch"
"openssl-c-rehash-in.patch"))))
(build-system gnu-build-system)
@@ -334,25 +333,6 @@ required structures.")
(license license:openssl)
(home-page "http://www.openssl.org/")))
-(define openssl/fixed
- (package
- (inherit openssl)
- (source
- (let ((name "openssl")
- (version "1.0.2h"))
- (origin
- (method url-fetch)
- (uri (list (string-append "ftp://ftp.openssl.org/source/"
- name "-" version ".tar.gz")
- (string-append "ftp://ftp.openssl.org/source/old/"
- (string-trim-right version char-set:letter)
- "/" name "-" version ".tar.gz")))
- (sha256
- (base32
- "06996ds1rk8xhnyb5y273a7xkcxhggp4bq1g02rab55d7bjhfh0x"))
- (patches (search-patches "openssl-runpath.patch"
- "openssl-c-rehash-in.patch")))))))
-
(define-public libressl
(package
(name "libressl")