summaryrefslogtreecommitdiff
path: root/gnu/packages/tor.scm
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2017-01-24 11:19:34 +0000
committerLeo Famulari <leo@famulari.name>2017-01-24 14:04:44 -0500
commit7c04154940b746fb872536ea6833f5ef8ddbe288 (patch)
treea25df7f6cf385469073fe89e5a99361cfb548da9 /gnu/packages/tor.scm
parentee869cd6eab6b0552380b64792452b77e55c9daf (diff)
gnu: tor: Update to 0.2.9.9 [fixes security issue TROVE-2017-001].
See 'ChangeLog' in the source distribution for more information about the denial of service bug TROVE-2017-001. * gnu/packages/tor.scm (tor): Update to 0.2.9.9. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/tor.scm')
-rw-r--r--gnu/packages/tor.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 6f26f404be..c7f97ab1b4 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -39,14 +39,14 @@
(define-public tor
(package
(name "tor")
- (version "0.2.9.8")
+ (version "0.2.9.9")
(source (origin
(method url-fetch)
(uri (string-append "https://dist.torproject.org/tor-"
version ".tar.gz"))
(sha256
(base32
- "0sklgmx4nikcfhqd606kvpwy1l8840w24ikli1xjjx25739k7pgv"))))
+ "0hqdk5p6dw4bpn7c8gmhyi8jjkhc37112pfw5nx4gl0g4lmmscik"))))
(build-system gnu-build-system)
(native-inputs
`(("python" ,python-2))) ; for tests