summaryrefslogtreecommitdiff
path: root/gnu/packages/toys.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-25 10:28:03 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-25 10:28:03 +0100
commit7bf4ce4582cd2f9c5b30c547262c1c4a426c0b9b (patch)
treec6f9cc83feaaf685b7542a98e60bc24ea7c297b1 /gnu/packages/toys.scm
parent06d01c610e3bee61e38a177aecda5982d5b338ae (diff)
parent92d8b4c9598ed32cdb6630433d5914c1ae8b7146 (diff)
Merge branch 'master' into gnome-team
Diffstat (limited to 'gnu/packages/toys.scm')
-rw-r--r--gnu/packages/toys.scm72
1 files changed, 72 insertions, 0 deletions
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index c058e70dac..576e439ea6 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023 Sarthak Shah <shahsarthakw@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -399,6 +400,77 @@ the desktop background. Additional customizable effects include wind, stars
and various scenery elements.")
(license license:gpl3+)))
+(define-public xpenguins
+ (package
+ (name "xpenguins")
+ (version "3.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://ratrabbit.nl/downloads/xpenguins/xpenguins-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "03qwc7gf21d2ixkrxxwwgayj6f5fv1kg4b7ggx90j5269il63adm"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'fix-install-path
+ (lambda _
+ ;; Install program to bin/ instead of games/.
+ (substitute* "src/Makefile.in"
+ (("(gamesdir = \\$\\(exec_prefix\\)/)games" _ prefix)
+ (string-append prefix "bin"))))))))
+ (inputs
+ (list gtk+ libx11 libxml2 libxpm libxt))
+ (native-inputs
+ (list pkg-config))
+ (home-page
+ "https://www.ratrabbit.nl/ratrabbit/software/xpenguins/index.html")
+ (synopsis "Let penguins take over your desktop!")
+ (description "Xpenguins is a vintage application showing penguins running,
+flying and falling on the desktop, using windows as run paths.")
+ (license license:gpl2+)))
+
+(define-public xfishtank
+ (package
+ (name "xfishtank")
+ (version "3.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://www.ratrabbit.nl/downloads/xfishtank/xfishtank-"
+ version "~pre1.tar.gz"))
+ ;; Version has ~pre1 in it. Guix store does not allow tilde in file
+ ;; names. Save it in the Store using a hyphen.
+ (file-name (string-append name "-" version "-pre1.tar.gz"))
+ (sha256
+ (base32 "16i9diawkmar6dhx5xn0mflr2h585gamab6137hvxzgaczx55lwp"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'fix-install-path
+ (lambda _
+ ;; Install program to bin/ instead of games/.
+ (substitute* "src/Makefile.in"
+ (("(gamesdir = \\$\\(exec_prefix\\)/)games" _ prefix)
+ (string-append prefix "bin"))))))))
+ (inputs
+ (list gtk+ libx11 libxml2 libxpm libxt))
+ (native-inputs
+ (list pkg-config))
+ (home-page
+ "https://www.ratrabbit.nl/ratrabbit/software/xfishtank/index.html")
+ (synopsis "Let fish swim over your desktop!")
+ (description "Xfishtank is a vintage application that uses the X11
+protocol. It shows fishes swimming over the desktop.")
+ (license (list license:expat license:gpl3+))))
+
(define-public nyancat
(package
(name "nyancat")