summaryrefslogtreecommitdiff
path: root/gnu/packages/toys.scm
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2023-05-19 01:30:14 -0400
committer宋文武 <iyzsong@member.fsf.org>2023-05-24 20:35:31 +0800
commit0b6bcc747d97a682e77abc07b426436d7213fdf8 (patch)
tree473059aad69b5ae4149748cfccd7442f73bd1c51 /gnu/packages/toys.scm
parentc57693846c7c6586c6cd1b4e4002fe399e3a2c42 (diff)
gnu: lolcat: Update to 1.4.
* gnu/packages/toys.scm (lolcat): Update to 1.4. [version]: Switch to release tag. [arguments]: Use G-expressions. Remove trailing #t. <#:phases>: Replace assoc-ref with #$output. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/toys.scm')
-rw-r--r--gnu/packages/toys.scm69
1 files changed, 33 insertions, 36 deletions
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index 8967c0c25b..21d5279e85 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -137,44 +137,41 @@ display via @command{fortune}, drawn from sources all around the world.")
(license license:unlicense))))
(define-public lolcat
- (let ((commit "35dca3d0a381496d7195cd78f5b24aa7b62f2154")
- (revision "0"))
- (package
- (name "lolcat")
- (version (git-version "1.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jaseg/lolcat")
- (commit commit)))
- (sha256
- (base32
- "0jjbkqcc2ikjxd1xgdyv4rb0vsw218181h89f2ywg29ffs3ypd8g"))
- (file-name (git-file-name name version))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; no check target
- #:make-flags
- (list ,(string-append "CC=" (cc-for-target)))
- #:phases
- (modify-phases %standard-phases
- (delete 'bootstrap)
- (delete 'configure)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (dest (string-append out "/bin")))
- (mkdir-p dest)
- (install-file "lolcat" dest)
- (install-file "censor" dest)
- #t))))))
- (home-page "https://github.com/jaseg/lolcat")
- (synopsis "Rainbow coloring effect for text console display")
- (description "@command{lolcat} concatenates files and streams like
+ (package
+ (name "lolcat")
+ (version "1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jaseg/lolcat")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0wyx184072z820njlc6qkvpxwcpjhj25gq4j0iw3jqzv3sk7mg7q"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ; no check target
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target)))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure)
+ (replace 'install
+ (lambda _
+ (let ((dest (string-append #$output "/bin")))
+ (mkdir-p dest)
+ (install-file "lolcat" dest)
+ (install-file "censor" dest)))))))
+ (home-page "https://github.com/jaseg/lolcat")
+ (synopsis "Rainbow coloring effect for text console display")
+ (description "@command{lolcat} concatenates files and streams like
regular @command{cat}, but it also adds terminal escape codes between
characters and lines resulting in a rainbow effect.")
- (license license:wtfpl2))))
+ (license license:wtfpl2)))
(define-public oneko
(package