summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:51 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:34 +0200
commitef294b8b5f119ea618ae6bb5e88b742b5a0857c3 (patch)
treecc7304637e213ad33f5403543b1e8a3ed7c6e0a9 /gnu/packages/tryton.scm
parent32b67eef8248977de8e2d83dae88e25ea627fdf1 (diff)
gnu: Add trytond-stock-package.
* gnu/packages/tryton.scm (trytond-stock-package): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 95be3eda7e..5674adae56 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3938,6 +3938,30 @@ it is no more used to compute the forecast quantity of the stock.")
unit and quantity on stock lot.")
(license license:gpl3+)))
+(define-public trytond-stock-package
+ (package
+ (name "trytond-stock-package")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_stock_package" version))
+ (sha256
+ (base32 "1jbpl141wyc19v27bcyqsph8p2zf9yqprm55yl642mvwq55bshq8"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "stock_package"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-company" ,trytond-company)
+ ("trytond-product" ,trytond-product)
+ ("trytond-stock" ,trytond-stock)))
+ (home-page "https://docs.tryton.org/projects/modules-stock-package")
+ (synopsis "Tryton module for stock packaging")
+ (description "The @emph{Stock Package} Tryton module allows to store
+packaging information about customer and supplier return shipments.")
+ (license license:gpl3+)))
+
(define-public trytond-stock-supply
(package
(name "trytond-stock-supply")