summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-07-19 16:37:40 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-08-10 14:27:26 +0200
commitc46b66450b3a09371bdb9a0daffb8868939582e9 (patch)
treea66798229f4337a7cdebad4fe2f23a8c949d5198 /gnu/packages/tryton.scm
parentd074c57ace69c0dcfcf071914324bbe9560c9f05 (diff)
gnu: Add trytond-stock-package-shipping-mygls.
* gnu/packages/tryton.scm (trytond-stock-package-shipping-mygls): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 15602c5fc7..2b35653142 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4062,6 +4062,31 @@ you to generate the DPD label using the DPD webservices. DPD has many
different web services, the module supports:")
(license license:gpl3+)))
+(define-public trytond-stock-package-shipping-mygls
+ (package
+ (name "trytond-stock-package-shipping-mygls")
+ (version "6.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_stock_package_shipping_mygls" version))
+ (sha256
+ (base32 "0pwq720mqv473s5aqib89z5bjdl127l8nqw91prxsna82bm16kv2"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "trytond_stock_package_shipping_mygls"))
+ (native-inputs (%standard-trytond-native-inputs))
+ (propagated-inputs (list python-pypdf2
+ trytond
+ trytond-carrier
+ trytond-stock
+ trytond-stock-package
+ trytond-stock-package-shipping
+ python-zeep))
+ (home-page "https://docs.tryton.org/projects/modules-stock-package-shipping-mygls")
+ (synopsis "MyGLS connector for the Tryton application platform")
+ (description "The @emph{Stock Package Shipping MyGLS} Tryton module allows
+package labels to be generated for shipments using MyGLS webservices.")
+ (license license:gpl3+)))
+
(define-public trytond-stock-package-shipping-ups
(package
(name "trytond-stock-package-shipping-ups")