summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:50 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:34 +0200
commitebfc61d1daab87929768e9037bd836b70f95ad65 (patch)
treec276d9bcb19f63e83b12cff09045e262596e9905 /gnu/packages/tryton.scm
parent4d6c24f5d1974bab56b52feb233ac653a6e37ae7 (diff)
gnu: Add trytond-stock-lot-sled.
* gnu/packages/tryton.scm (trytond-stock-lot-sled): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index d147709c6b..b1cc3b9ef1 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3886,6 +3886,32 @@ ordering to location.")
(define-public python-trytond-stock-lot
(deprecated-package "python-trytond-stock-lot" trytond-stock-lot))
+(define-public trytond-stock-lot-sled
+ (package
+ (name "trytond-stock-lot-sled")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_stock_lot_sled" version))
+ (sha256
+ (base32 "1x8sjhgbakqbgfhrrl7b1b0961riqibs6q6lmgmyrvjyrxx0hpig"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "stock_lot_sled"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-product" ,trytond-product)
+ ("trytond-stock" ,trytond-stock)
+ ("trytond-stock-lot" ,trytond-stock-lot)))
+ (home-page "https://docs.tryton.org/projects/modules-stock-lot-sled")
+ (synopsis "Tryton module for shelf life expiration date of product lots")
+ (description "The @emph{Stock Lot Sled} Tryton module adds the \"Shelf
+Live Expiration Date\" anf \"Expiration Date\" on \"lot of products\". When
+the shelf life of a lot expires in less than the configured shelf life delay,
+it is no more used to compute the forecast quantity of the stock.")
+ (license license:gpl3+)))
+
(define-public trytond-stock-supply
(package
(name "trytond-stock-supply")