summaryrefslogtreecommitdiff
path: root/gnu/packages/u-boot.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-09-08 17:10:42 +0200
committerDavid Craven <david@craven.ch>2016-09-13 19:04:43 +0200
commite42a0771b7d7f0661be459658e31f5d65843ed75 (patch)
treec64da63ce7df5897a2986dc77602d475629a3edf /gnu/packages/u-boot.scm
parent243db8245e6d8ee6aae80ce4606fb58cb8b23443 (diff)
gnu: dtc: Remove patch-paths phase.
* gnu/packages/u-boot.scm (dtc)[arguments]: Remove patch-paths phase. [configure-flags]: Add INSTALL. Signed-off-by: David Craven <david@craven.ch>
Diffstat (limited to 'gnu/packages/u-boot.scm')
-rw-r--r--gnu/packages/u-boot.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/u-boot.scm b/gnu/packages/u-boot.scm
index e9a4b90941..7949d8a4c3 100644
--- a/gnu/packages/u-boot.scm
+++ b/gnu/packages/u-boot.scm
@@ -47,15 +47,11 @@
("flex" ,flex)))
(arguments
`(#:make-flags
- (list "CC=gcc" (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ (list "CC=gcc"
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "INSTALL=install")
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-paths
- (lambda _
- (substitute* "Makefile"
- (("/usr/bin/install") "install"))
- (substitute* "Makefile"
- (("PREFIX = \\$\\(HOME\\)") ""))))
(delete 'configure))))
(home-page "https://www.devicetree.org")
(synopsis "Compiles device tree source files")