summaryrefslogtreecommitdiff
path: root/gnu/packages/valgrind.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 21:43:24 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 23:37:06 -0400
commitfa2c1689c8972a1cdd111bcbc114c25fbf447904 (patch)
treeff93096765477ca21ae1cedafaf72777fdf2514d /gnu/packages/valgrind.scm
parentcfe4a07775fc542b431bdf0d94788b85088ff8c4 (diff)
gnu: valgrind/interactive: Rely on non-stripped glibc symbols.
* gnu/packages/valgrind.scm (valgrind/interactive) [source]: Remove patches. [arguments]: Delete field. * gnu/packages/patches/valgrind-fix-default-debuginfo-path.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it.
Diffstat (limited to 'gnu/packages/valgrind.scm')
-rw-r--r--gnu/packages/valgrind.scm39
1 files changed, 1 insertions, 38 deletions
diff --git a/gnu/packages/valgrind.scm b/gnu/packages/valgrind.scm
index bd08dffc83..204dd4a3c5 100644
--- a/gnu/packages/valgrind.scm
+++ b/gnu/packages/valgrind.scm
@@ -106,45 +106,8 @@ also use Valgrind to build new tools.")
"/valgrind-" version ".tar.bz2")))
(sha256
(base32
- "1ipkp6yi202pml2r0qwflysmq86dkqd8iyi1y51d6y70vcqw0dl5"))
- (patches (search-patches
- "valgrind-fix-default-debuginfo-path.patch"))))
+ "1ipkp6yi202pml2r0qwflysmq86dkqd8iyi1y51d6y70vcqw0dl5"))))
(inputs
;; GDB is needed to provide a sane default for `--db-command'.
(list gdb `(,(canonical-package glibc) "debug")))
- (arguments
- (substitute-keyword-arguments (package-arguments valgrind)
- ((#:phases phases #~%standard-phases)
- #~(modify-phases #$phases
- (add-before 'configure 'patch-default-debuginfo-path
- (lambda* (#:key inputs #:allow-other-keys)
- ;; This helps Valgrind find the debug symbols of ld.so.
- ;; Without it, Valgrind does not work in a Guix shell
- ;; container and cannot be used as-is during packages tests
- ;; phases.
- ;; TODO: Remove on the next rebuild cycle, when libc is not
- ;; longer fully stripped.
- (define libc-debug
- (string-append (ungexp (this-package-input "glibc") "debug")
- "/lib/debug"))
-
- (substitute* '("coregrind/m_debuginfo/readelf.c"
- "docs/xml/manual-core-adv.xml"
- "docs/xml/manual-core.xml")
- (("DEFAULT_DEBUGINFO_PATH")
- libc-debug))
- ;; We also need to account for the bigger path in
- ;; the malloc-ed variables.
- (substitute* '("coregrind/m_debuginfo/readelf.c")
- (("DEBUGPATH_EXTRA_BYTES_1")
- (number->string
- (+ (string-length libc-debug)
- (string-length "/.build-id//.debug")
- 1))))
- (substitute* '("coregrind/m_debuginfo/readelf.c")
- (("DEBUGPATH_EXTRA_BYTES_2")
- (number->string
- (+ (string-length libc-debug)
- (string-length "/usr/lib/debug")
- 1))))))))))
(properties '())))