summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-22 21:31:02 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-23 10:00:25 -0400
commit1415d964abfc7da55ddb3156e1aa4d64f7169d85 (patch)
tree5de86e5df3a761edd8b6d2df8b759508dc04dc20 /gnu/packages/version-control.scm
parent0e2e1ffc95cbeff20fbafd6c18000e94d0924f1b (diff)
gnu: python-pre-commit: Move deprecated variable next to replacement.
This fixes a module import dependency cycle, which was introduced in 831baaf81e57ce9d9053ba6f9e0653a2d27298c4 ("gnu: python-pre-commit: Replace with pre-commit."). The rule of thumb to avoid these is that the deprecated package should live next to the replacement package (in the same module). * gnu/packages/python-xyz.scm (python-pre-commit): Move to... * gnu/packages/version-control.scm (python-pre-commit): ... here.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index c9fb66c8c9..c270b4257b 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1757,6 +1757,9 @@ specify a list of hooks you want and pre-commit manages the installation and
execution of any hook written in any language before every commit.")
(license license:expat)))
+(define-public python-pre-commit
+ (deprecated-package "python-pre-commit" pre-commit))
+
(define-public mercurial
(package
(name "mercurial")