summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-06-27 09:42:06 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-27 09:42:06 +0200
commit98378db6bac5ad7b4fa680f832ade78dd0bcce95 (patch)
tree1f7aed0ed04247f99b6c9084db26c5fb34f9d6f0 /gnu/packages/version-control.scm
parent01497dfe6c0a2ce69287d0fd0008747965a000df (diff)
gnu: git: Use 'modify-phases'.
* gnu/packages/version-control.scm (git)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm39
1 files changed, 18 insertions, 21 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 2b2076c484..9d5a808e3b 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -166,25 +166,23 @@ as well as the classic centralized workflow.")
#:modules ((srfi srfi-1)
,@%gnu-build-system-modules)
#:phases
- (alist-cons-after
- 'configure 'patch-makefile-shebangs
- (lambda _
- (substitute* "Makefile"
- (("/bin/sh") (which "sh"))
- (("/usr/bin/perl") (which "perl"))
- (("/usr/bin/python") (which "python"))))
- (alist-cons-after
- 'install 'install-shell-completion
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (completions (string-append out "/etc/bash_completion.d")))
- ;; TODO: Install the tcsh and zsh completions in the right place.
- (mkdir-p completions)
- (copy-file "contrib/completion/git-completion.bash"
- (string-append completions "/git"))
- #t))
- (alist-cons-after
- 'install 'split
+ (modify-phases %standard-phases
+ (add-after 'configure 'patch-makefile-shebangs
+ (lambda _
+ (substitute* "Makefile"
+ (("/bin/sh") (which "sh"))
+ (("/usr/bin/perl") (which "perl"))
+ (("/usr/bin/python") (which "python")))))
+ (add-after 'install 'install-shell-completion
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (completions (string-append out "/etc/bash_completion.d")))
+ ;; TODO: Install the tcsh and zsh completions in the right place.
+ (mkdir-p completions)
+ (copy-file "contrib/completion/git-completion.bash"
+ (string-append completions "/git"))
+ #t)))
+ (add-after 'install 'split
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Split the binaries to the various outputs.
(let* ((out (assoc-ref outputs "out"))
@@ -256,8 +254,7 @@ as well as the classic centralized workflow.")
;; specify a single directory, not a search path.
(wrap-program (string-append out "/bin/git")
`("PATH" ":" prefix
- ("$HOME/.guix-profile/libexec/git-core")))))
- %standard-phases)))))
+ ("$HOME/.guix-profile/libexec/git-core")))))))))
(native-search-paths
;; For HTTPS access, Git needs a single-file certificate bundle, specified