summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-07-22 15:45:15 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-07-22 18:24:22 +0300
commitaac42d78852daa7930f79f1c1061f1558f93abd3 (patch)
tree1d4606a47e638e96ff2558e874f0e930efa1d84e /gnu/packages/version-control.scm
parent430e67a4596343ed215bee649fa13cca7687451f (diff)
gnu: git-flow: Use 'modify-phases'.
* gnu/packages/version-control.scm (git-flow)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 6d0d4f991d..0ad9f1c28a 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -490,19 +490,19 @@ will work.")
'(#:tests? #f ; no tests
#:make-flags (list (string-append "prefix="
(assoc-ref %outputs "out")))
- #:phases (alist-cons-after
- 'unpack 'reset-shFlags-link
- (lambda* (#:key inputs #:allow-other-keys)
- ;; The link points to a file in the shFlags submodule.
- ;; Redirect it to point to our system shFlags.
- (let ((shflags (assoc-ref inputs "shflags")))
- (begin
- (delete-file "gitflow-shFlags")
- (symlink (string-append shflags "/src/shflags")
- "gitflow-shFlags"))))
- (alist-delete
- 'configure
- (alist-delete 'build %standard-phases)))))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'reset-shFlags-link
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; The link points to a file in the shFlags submodule.
+ ;; Redirect it to point to our system shFlags.
+ (let ((shflags (assoc-ref inputs "shflags")))
+ (begin
+ (delete-file "gitflow-shFlags")
+ (symlink (string-append shflags "/src/shflags")
+ "gitflow-shFlags")))))
+ (delete 'configure)
+ (delete 'build))))
(home-page "http://nvie.com/posts/a-successful-git-branching-model/")
(synopsis "Git extensions for Vincent Driessen's branching model")
(description