summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorJessica Tallon <tsyesika@tsyesika.se>2022-11-15 22:02:33 +0100
committerLudovic Courtès <ludo@gnu.org>2022-11-28 23:34:16 +0100
commit3cff7bfa9b46f1b73381df79a6f2aaa55a332126 (patch)
treec742317504ad1d8ecb0843a1c19e256bed159f4b /gnu/packages/video.scm
parentc1b71a443210b9688a116a43fef2d284fc99e953 (diff)
gnu: Add svtplay-dl.
* gnu/packages/video.scm (svtplay-dl): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 70a9cd4033..297252d1ae 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -5606,3 +5606,27 @@ VCS, by default, makes screenshots the same size as the video, see the manual
for details on how to change this.")
(home-page "http://p.outlyer.net/vcs/")
(license license:lgpl2.1+)))
+
+(define-public svtplay-dl
+ (package
+ (name "svtplay-dl")
+ (version "4.14")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/spaam/svtplay-dl")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1wdrdszalvhv80m5jizbvjz4jc08acmbpxcsslyfb5cwh842in8m"))))
+ (build-system python-build-system)
+ (inputs (list ffmpeg python-pyaml python-requests python-pysocks
+ python-cryptography))
+ (home-page "https://svtplay-dl.se/")
+ (synopsis "Download or stream SVT Play's (and others) TV programmes")
+ (description
+ "@code{svtplay-dl} allows downloading TV programmes from various Swedish
+broadcasters including SVT Play, Sveriges Radio, TV4 Play, along with many
+others.")
+ (license license:expat)))