summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-04-23 20:20:51 -0400
committerLeo Famulari <leo@famulari.name>2023-04-23 20:36:13 -0400
commita0b2b4f1e95b876cbf5a3b8ca25f901504fc1acf (patch)
tree1375d910fcefd1f3a106161ce318bf9901d4d395 /gnu/packages/video.scm
parent5bcf10867ddbded3de76ba15d9e8113cb648a0ca (diff)
gnu: libmediainfo and mediainfo: Fix build.
* gnu/packages/video.scm (libmediainfo, mediainfo)[arguments]: Add a shebang to the autogen.sh script in the 'change-to-build-dir' phases.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 240730844a..5d7347cf5e 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4183,6 +4183,13 @@ practically any type of media.")
(add-after 'unpack 'change-to-build-dir
(lambda _
(chdir "Project/GNU/Library")
+ ;; XXX Add a shebang to the script to avoid an error like:
+ ;; "In execvp of ./autogen.sh: Exec format error"
+ ;; The string replaced is just a code comment.
+ ;; See the similar substitution made in mediainfo.
+ (substitute* "autogen.sh"
+ (("#libtoolize")
+ "#!/bin/sh"))
#t)))))
(home-page "https://mediaarea.net/en/MediaInfo")
(synopsis "Library for retrieving media metadata")
@@ -4238,6 +4245,13 @@ MPEG-2, MPEG-4, DVD (VOB)...
(add-after 'unpack 'change-to-build-dir
(lambda _
(chdir "Project/GNU/CLI")
+ ;; XXX Add a shebang to the script to avoid an error like:
+ ;; "In execvp of ./autogen.sh: Exec format error"
+ ;; The string replaced is just a code comment.
+ ;; See the similar substitution made in libmediainfo.
+ (substitute* "autogen.sh"
+ (("#libtoolize")
+ "#!/bin/sh"))
#t)))))
(home-page "https://mediaarea.net/en/MediaInfo")
(synopsis "Utility for reading media metadata")