summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-02-21 20:08:27 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-03-09 12:34:04 -0500
commita723a7b3b77af9a3f196fd68dc593d012389ad95 (patch)
treef11e4dcb12f6c6574733dc757d2d3ec29ecbf613 /gnu/packages/video.scm
parentf4078087a69e4f57059fc6120332b47caef3aeaf (diff)
Revert "gnu: mpv: Propagate most libraries."
This reverts commit f3fdb4e041cb5740ba0b38b9ad017571f8414d33. This is made possible by having replaced pkg-config with pkgconf, which more strictly interprets the private fields as purely for static compilation. Series-to: 68813@debbugs.gnu.org Series-prefix: core-updates Cover-letter: Replace pkg-config with pkgconf to reduce propagation / Inkscape updates As demonstrated in this series, pkgconf's improved behavior for private fields mean we do not need to propagate them in the usual case (shared linking), which in turn means we can reduce the number of propagated inputs. This series also explore removing libtool archives (.la) files, as these also introduce the need to propagate libraries. Moreover, they cause overlinking in the context of ELF shared libraries. END Change-Id: I1c06623a4501bbcddfb80aa3cfd79a08409a08ae
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm33
1 files changed, 13 insertions, 20 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index fa6688b62a..aeb1b80b05 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2646,43 +2646,31 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
"-Ddvdnav=enabled"
"-Dbuild-date=false")))
(native-inputs
- (list perl ;for zsh completion file
- pkg-config
- python-docutils
- python-wrapper))
+ (list perl ; for zsh completion file
+ pkg-config python-docutils python-wrapper))
;; Missing features: libguess, V4L2.
(inputs
- (list enca
- ladspa
- lcms
- libbs2b
- mpg123
- rsound
- vulkan-headers
- vulkan-loader
- yt-dlp))
- ;; XXX: These are propagated for the mpv pkg-config package, as they are
- ;; listed in Requires.private and would break 'pkg-config --exists mpv' if
- ;; unavailable.
- (propagated-inputs
(list alsa-lib
+ enca
ffmpeg
jack-1
+ ladspa
+ lcms
libass
libbluray
libcaca
+ libbs2b
libcdio-paranoia
- libdrm
- libdvdnav
libdvdread
+ libdvdnav
libjpeg-turbo
libplacebo
libva
libvdpau
libx11
libxext
- libxinerama
libxkbcommon
+ libxinerama
libxpresent
libxrandr
libxscrnsaver
@@ -2690,10 +2678,15 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
;; XXX: lua > 5.2 is not currently supported; see meson.build
lua-5.2
mesa
+ mpg123
pulseaudio
+ rsound
shaderc
+ vulkan-headers
+ vulkan-loader
wayland
wayland-protocols
+ yt-dlp
zimg
zlib))
(home-page "https://mpv.io/")