summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-02-19 12:43:52 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:11:34 -0400
commitaee59d5af7e5759fb8201e63624d438b4bd118f6 (patch)
tree608e058d9ecc3a8f95264da67a42a83f7e411d95 /gnu/packages/video.scm
parent6d9597088dbc7795278309dddeaafbce761c98ca (diff)
gnu: rav1e: Fix building.
* gnu/packages/video.scm (rav1e)[source]: Remove outdated snippet. [arguments]: Remove custom 'force-rust-edition-2018 phase.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm15
1 files changed, 2 insertions, 13 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 9f3aa998b2..8ecbaa2602 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -5286,12 +5286,7 @@ result in several formats:
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "006bfcmjwg0phg8gc25b1sl2ngjrb2bh1b3fd0s5gbf9nlkr8qsn"))
- (modules '((guix build utils)))
- (snippet
- '(substitute* "Cargo.toml"
- (("\\[package\\]" m)
- (string-append "cargo-features = [\"rust-version\"]\n" m))))))
+ "006bfcmjwg0phg8gc25b1sl2ngjrb2bh1b3fd0s5gbf9nlkr8qsn"))))
(build-system cargo-build-system)
(arguments
`(;; Strip the '--release' flag to work around the doctest failures with
@@ -5354,14 +5349,8 @@ result in several formats:
(add-after 'unpack 'relax-versions
(lambda _
(substitute* "Cargo.toml"
- ;; Allow using more recent versions of
+ ;; Allow using more recent versions of system-deps.
(("~3.1.2") "~3"))))
- (add-after 'configure 'force-rust-edition-2018
- (lambda* (#:key vendor-dir #:allow-other-keys)
- ;; Force all the dependencies to not be higher than edition 2018.
- (with-fluids ((%default-port-encoding #f))
- (substitute* (find-files vendor-dir "Cargo.toml")
- (("edition = \\\"2021\\\"") "edition = \"2018\"")))))
(replace 'build
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))