summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2023-12-14 00:57:38 +0800
committerHilton Chain <hako@ultrarare.space>2023-12-22 21:58:11 +0800
commitce7b2b57aa6da0ceace94ea5fb42392c7ff97d53 (patch)
tree78940978532341f58bfa400a490989b24fa9071f /gnu/packages/video.scm
parent8b249a1be69874d029cd8a2d2ff170f9007c5fc4 (diff)
gnu: mpv: Update to 0.37.0.
* gnu/packages/video.scm (mpv): Update to 0.37.0. [build-system]: Switch to meson-build-system. [arguments]<#:configure-flags>: Adjust accordingly. <#:phases>: Remove set-up-waf phase. <#:tests?>: Remove argument. [native-inputs]: Add python-wrapper. [inputs]: Add libplacebo, zimg. Remove python-waf. Change-Id: I0e61761a4d086a1185730f587869c2552b7cacb0 Signed-off-by: Hilton Chain <hako@ultrarare.space>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm30
1 files changed, 12 insertions, 18 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 30ad11314a..6da4897a57 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2339,7 +2339,7 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
(define-public mpv
(package
(name "mpv")
- (version "0.36.0")
+ (version "0.37.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2347,8 +2347,8 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1ri06h7pv6hrxmxxc618n9hymlgr0gfx38bqq5dcszdgnlashsgk"))))
- (build-system waf-build-system)
+ (base32 "1xcyfpd543lbmg587wi0mahrz8vhyrlr4432054vp6wsi3s36c4b"))))
+ (build-system meson-build-system)
(arguments
(list
#:phases
@@ -2365,21 +2365,15 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
;; and passed as linker flags, but the order in which they are added
;; varies. See <https://github.com/mpv-player/mpv/issues/7855>.
;; Set PYTHONHASHSEED as a workaround for deterministic results.
- (setenv "PYTHONHASHSEED" "1")))
- (add-before 'configure 'set-up-waf
- (lambda* (#:key inputs #:allow-other-keys)
- (copy-file (search-input-file inputs "bin/waf") "waf")
- (setenv "CC" #$(cc-for-target)))))
+ (setenv "PYTHONHASHSEED" "1"))))
#:configure-flags
- #~(list "--enable-libmpv-shared"
- "--enable-cdda"
- "--enable-dvdnav"
- "--disable-build-date")
- ;; No check function defined.
- #:tests? #f))
+ #~(list "-Dlibmpv=true"
+ "-Dcdda=enabled"
+ "-Ddvdnav=enabled"
+ "-Dbuild-date=false")))
(native-inputs
(list perl ; for zsh completion file
- pkg-config python-docutils))
+ pkg-config python-docutils python-wrapper))
;; Missing features: libguess, V4L2.
(inputs
(list alsa-lib
@@ -2396,6 +2390,7 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
libdvdread
libdvdnav
libjpeg-turbo
+ libplacebo
libva
libvdpau
libx11
@@ -2406,13 +2401,11 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
libxrandr
libxscrnsaver
libxv
- ;; XXX: lua > 5.2 is not currently supported; see
- ;; waftools/checks/custom.py
+ ;; XXX: lua > 5.2 is not currently supported; see meson.build
lua-5.2
mesa
mpg123
pulseaudio
- python-waf
rsound
shaderc
vulkan-headers
@@ -2420,6 +2413,7 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
wayland
wayland-protocols
yt-dlp
+ zimg
zlib))
(home-page "https://mpv.io/")
(synopsis "Audio and video player")