summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2024-02-22 20:47:54 +0100
committerLars-Dominik Braun <lars@6xq.net>2024-06-30 09:19:47 +0200
commit35eca45e9a26a44d5e945a7eee8a15312f770d2c (patch)
tree1a4fd8fa034116798aa12e233b95a6526ce77eb1 /gnu/packages/video.scm
parentda7edf3ccb2153f14accc3a9dfffe871d0b16279 (diff)
gnu: Add python-setuptools/python-wheel where necessary.
Changes to pyproject-build-system require explicit dependency on setuptools/wheel. Change-Id: Icd7699fc1dc56e974ae7568f2ae916dbf876bea5
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index dcd8cc302e..c142bab46f 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2323,6 +2323,7 @@ videoformats depend on the configuration flags of ffmpeg.")
`("PATH" ":" prefix
(,(search-input-file inputs ffm))))))))))
(inputs (list bash-minimal ffmpeg))
+ (native-inputs (list python-setuptools python-wheel))
(home-page "https://github.com/slhck/ffmpeg-progress-yield")
(synopsis "Run an ffmpeg command with progress")
(description "This package allows an ffmpeg command to run with progress.
@@ -2356,7 +2357,7 @@ It is usually a complement to @code{ffmpeg-normalize}.")
(ffm (search-input-file inputs "bin/ffmpeg")))
(wrap-program ffn
`("FFMPEG_PATH" = (,ffm)))))))))
- (native-inputs (list python-pytest))
+ (native-inputs (list python-pytest python-setuptools python-wheel))
(inputs (list bash-minimal ffmpeg))
(propagated-inputs (list ffmpeg-progress-yield
python-colorama