summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-12-03 10:34:03 +0100
committerOleg Pykhalov <go.wigust@gmail.com>2024-01-21 16:00:51 +0300
commit14db6616e8e4a8d8cca3772d3aeb710bc5088081 (patch)
tree6217632922ac9ee53ed74ea0adfc2a82e305a786 /gnu/packages/video.scm
parentcbb4d8cb27b3d0b2cdd5919670b13a84f04468f5 (diff)
gnu: Add h264bitstream.
* gnu/packages/video.scm (h264bitstream): New variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 90b3bdb585..cca0217e61 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4545,6 +4545,39 @@ of modern, widely supported codecs.")
;; Combination under GPLv2. See LICENSE.
(license license:gpl2)))
+(define-public h264bitstream
+ ;; Used as submodule in https://github.com/moonlight-stream/moonlight-qt
+ (let ((commit "34f3c58afa3c47b6cf0a49308a68cbf89c5e0bff")
+ (revision "1"))
+ (package
+ (name "h264bitstream")
+ (version (git-version "0.2.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aizvorski/h264bitstream")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0rrhzckz2a89q0chw2bfl4g89yiv9a0dcqcj80lcpdr3a1ix8q85"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ;no test suite
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'fix-include-bs-h
+ (lambda _
+ (symlink (string-append #$output
+ "/include/h264bitstream/bs.h")
+ (string-append #$output "/include/bs.h")))))))
+ (native-inputs (list autoconf automake libtool pkg-config))
+ (inputs (list ffmpeg))
+ (synopsis "Library to read and write H.264 video bitstreams")
+ (description
+ "This package provides the GameStream code shared between Moonlight clients.")
+ (home-page "https://github.com/aizvorski/h264bitstream")
+ (license license:lgpl2.1+))))
+
(define-public intel-vaapi-driver
(package
(name "intel-vaapi-driver")