summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-09-24 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-09-24 02:00:00 +0200
commitb2ab38cd82acd8164383335af084f5da4a499332 (patch)
treeaaf1f8a5930d5ffcdfcecff2bb983009da223af3 /gnu/packages/video.scm
parent79abbaf4e48a08d30f0f967a99b2db764c882801 (diff)
gnu: libvpx: Graft to fix CVE-2023-5217.
* gnu/packages/video.scm (libvpx)[replacement]: New field, set to… (libvpx/fixed): …this new variable. * gnu/packages/patches/libvpx-CVE-2023-5217.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index d4afdfd21e..bb6cf75821 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2395,6 +2395,7 @@ To load this plugin, specify the following option when starting mpv:
(package
(name "libvpx")
(version "1.12.0")
+ (replacement libvpx/fixed)
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2433,6 +2434,15 @@ To load this plugin, specify the following option when starting mpv:
(license license:bsd-3)
(home-page "https://www.webmproject.org/")))
+(define libvpx/fixed
+ (package
+ (inherit libvpx)
+ (source
+ (origin
+ (inherit (package-source libvpx))
+ (patches (search-patches "libvpx-CVE-2016-2818.patch"
+ "libvpx-CVE-2023-5217.patch"))))))
+
(define-public orf-dl
(let ((commit "2dbbe7ef4e0efe0f3c1d59c503108e22d9065999")
(revision "1"))