summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-06 21:11:47 -0400
committerMark H Weaver <mhw@netris.org>2015-07-06 21:17:05 -0400
commit723e886656927f1290596407f2847bee254260d0 (patch)
tree3fceb9c48e6ad293a4baf04abf54f8ccdc045f13 /gnu/packages/video.scm
parent9ed548643918bb9415b16707f360f49fcab89627 (diff)
gnu: libvpx: Update to 1.4.0.
* gnu/packages/patches/libvpx-fix-armhf-link.patch, gnu/packages/patches/libvpx-fix-ssse3-quantize.patch, gnu/packages/patches/libvpx-vp9-out-of-bounds-access.patch: Remove files. * gnu-system.am (dist_patch_DATA): Remove them. * gnu/packages/video.scm (libvpx): Update to 1.4.0. Remove patches. Update source URI.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 6a5a250dc0..0c2c7d47a2 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -802,18 +802,15 @@ projects while introducing many more.")
(define-public libvpx
(package
(name "libvpx")
- (version "1.3.0")
+ (version "1.4.0")
(source (origin
(method url-fetch)
- (uri (string-append "http://webm.googlecode.com/files/libvpx-v"
- version ".tar.bz2"))
+ (uri (string-append "http://storage.googleapis.com/"
+ "downloads.webmproject.org/releases/webm/"
+ name "-" version ".tar.bz2"))
(sha256
(base32
- "1aai0h0z1bhp89pxmg4fkrwpmqq24k39fhr15cw6q77m9bccip6k"))
- (patches
- (list (search-patch "libvpx-vp9-out-of-bounds-access.patch")
- (search-patch "libvpx-fix-ssse3-quantize.patch")
- (search-patch "libvpx-fix-armhf-link.patch")))))
+ "1r0ql5kgy0c8mh5w7iiqvsd7w5njl9f9cclc7m52ln8assrdk0pm"))))
(build-system gnu-build-system)
(arguments
`(#:phases (alist-replace