summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-08-19 00:51:46 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-19 00:53:31 +0200
commit0d792f37cdc723b593645bb871afefd699d5165b (patch)
treea5fba4d5c83c5eca72a1288cbcbbb425269fc06e /gnu/packages/video.scm
parentf87860166e050905474cb54be79d6dc203ac5b3e (diff)
Revert "gnu: Add libde265."
This reverts commit 7f3c9116bdd349d49d3f6a148bc59f7f8d64215a, which would have introduced a duplicate definition.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm38
1 files changed, 0 insertions, 38 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 80a2b3319f..9563ddf50b 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -420,44 +420,6 @@ applications by providing high-level classes for commonly required tasks.")
(home-page "https://dirk-farin.net/software/libvideogfx/index.html")
(license license:lgpl2.1+)))
-(define-public libde265
- (package
- (name "libde265")
- (version "1.0.5")
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/strukturag/libde265.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1qisj8ryzbknam3hk81rq70fsd9mcpxm898bqygvbsmbwyvmz3pg"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)
- ("python" ,python-wrapper)))
- (inputs
- `(;; XXX: Build fails with libvideogfx.
- ;; ("libvideogfx" ,libvideogfx)
- ("qt" ,qtbase)
- ("sdl" ,sdl)))
- (synopsis "H.265 video codec implementation")
- (description "Libde265 is an implementation of the h.265 video codec. It is
-written from scratch and has a plain C API to enable a simple integration into
-other software.")
- (home-page "https://www.libde265.org/")
- (license
- (list
- ;; Applications.
- license:expat
- ;; Library.
- license:lgpl3+))))
-
(define-public tslib
(package
(name "tslib")