summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2019-08-22 15:53:27 -0400
committerMark H Weaver <mhw@netris.org>2019-08-22 15:53:27 -0400
commit893c2df00daa4e6dd6a7ff3813d7df5329877f9e (patch)
treeacd0db459464acae47083b66d5ce12cc656e2f10 /gnu/packages/video.scm
parent04b9b7bb05aff4c41f46cd79aa7bc953ace16e86 (diff)
parent0ccc9a0f5bb89b239d56157ea66f8420fcec5ba6 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm44
1 files changed, 23 insertions, 21 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 7225e9e5da..2376f8bda1 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1052,7 +1052,7 @@ videoformats depend on the configuration flags of ffmpeg.")
(define-public vlc
(package
(name "vlc")
- (version "3.0.7.1")
+ (version "3.0.8")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1061,7 +1061,7 @@ videoformats depend on the configuration flags of ffmpeg.")
"/vlc-" version ".tar.xz"))
(sha256
(base32
- "1xb4c8n0hkwijzfdlbwadhxnx9z8rlhmrdq4c7q74rq9f51q0m86"))))
+ "1xmxjpyzdhabchwncz6lvx3kzvl7fz9c42bkv3nbj68albs9w570"))))
(build-system gnu-build-system)
(native-inputs
`(("flex" ,flex)
@@ -3378,30 +3378,32 @@ online.")
(license license:expat)))
(define-public vidstab
- (package
- (name "vidstab")
- (version "1.1.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/georgmartius/vid.stab.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0a3frpm2kdbx7vszhg64p3alisag73bcspl7fp3a2f1kgq7rbh38"))))
- (build-system cmake-build-system)
- (arguments
- '(#:tests? #f)) ; tests are not run as part of standard build process
- (home-page "http://public.hronopik.de/vid.stab/")
- (synopsis "Video stabilization library")
- (description "Vidstab is a video stabilization library which can be used
+ (let ((commit "aeabc8daa7904f9edf7441a11f293965a5ef53b8")
+ (revision "0"))
+ (package
+ (name "vidstab")
+ (version (git-version "1.1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/georgmartius/vid.stab.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "042iy0f3khwzr68djzvqgn301sy21ljvkf52rnc2c73q7ircnzzn"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f)) ; tests are not run as part of standard build process
+ (home-page "http://public.hronopik.de/vid.stab/")
+ (synopsis "Video stabilization library")
+ (description "Vidstab is a video stabilization library which can be used
with FFmpeg. A video acquired using a hand-held camera or a camera mounted on a
vehicle typically suffers from undesirable shakes and jitters. Activities such
as surfing, skiing, riding and walking while shooting videos are especially
prone to erratic camera shakes. Vidstab targets these video contents to help
create smoother and stable videos.")
- (license license:gpl2+)))
+ (license license:gpl2+))))
(define-public libopenshot
(package