summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-04-14 13:07:16 -0400
committerLeo Famulari <leo@famulari.name>2017-04-14 13:07:16 -0400
commitc57ce31a896f659a2e311c2ee90b9027f4a405bc (patch)
tree17d0d0238ca1db65cce1f2ac68273af0483c9e7d /gnu/packages/video.scm
parentf575efa12c5df9f9879b7be0fe3593a3106a346d (diff)
parent8439c9c05eab5c98d889fb1de56bc78f62a8058f (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm30
1 files changed, 28 insertions, 2 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 3a72887f83..f6dab288e3 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2017 Feng Shu <tumashu@163.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -984,7 +985,7 @@ access to mpv's powerful playback capabilities.")
(define-public youtube-dl
(package
(name "youtube-dl")
- (version "2017.03.26")
+ (version "2017.04.14")
(source (origin
(method url-fetch)
(uri (string-append "https://yt-dl.org/downloads/"
@@ -992,7 +993,7 @@ access to mpv's powerful playback capabilities.")
version ".tar.gz"))
(sha256
(base32
- "00ysv18p4rqg7sswbpjpmmvaih6nm135bpllqdlj4ns8kjqmh59j"))))
+ "1rjc4ilafzrig02znrlxwjyzk5rpcc3li55n8rw2c4dmjmvjppkh"))))
(build-system python-build-system)
(arguments
;; The problem here is that the directory for the man page and completion
@@ -1023,6 +1024,31 @@ YouTube.com and a few more sites.")
(home-page "https://yt-dl.org")
(license license:public-domain)))
+(define-public you-get
+ (package
+ (name "you-get")
+ (version "0.4.652")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/soimort/you-get/releases/download/v"
+ version "/you-get-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0brkz98lycx8mmxjwmn7jlhqfdbvl0hy070n7skwr1k75kh99q30"))))
+ (build-system python-build-system)
+ (arguments
+ ;; no tests
+ '(#:tests? #f))
+ (inputs
+ `(("ffmpeg" ,ffmpeg)))
+ (synopsis "Download videos, audios, or images from Web sites")
+ (description
+ "You-Get is a command-line utility to download media contents (videos,
+audio, images) from the Web. It can use either mpv or vlc for playback.")
+ (home-page "https://you-get.org/")
+ (license license:expat)))
+
(define-public libbluray
(package
(name "libbluray")