summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2016-07-06 18:55:54 -0500
committerEfraim Flashner <efraim@flashner.co.il>2016-07-10 07:10:55 +0300
commit6cf83e3f83a9373d0da2ea3b29597c370133c9ff (patch)
treee9616bd80f42e349e03192469d1df801f0c74cac /gnu/packages/video.scm
parent9d5448f35f8d933c7dd54427bf6b3186a5154919 (diff)
gnu: mpv: Enable shared library support.
* gnu/packages/video.scm (mpv): Enable shared library support. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 2332a0d509..ae1813db1d 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2015 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -818,7 +819,7 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
(lambda* (#:key inputs #:allow-other-keys)
(copy-file (assoc-ref inputs "waf") "waf")
(setenv "CC" "gcc"))))
- #:configure-flags (list "--enable-zsh-comp")
+ #:configure-flags (list "--enable-libmpv-shared" "--enable-zsh-comp")
;; No check function defined.
#:tests? #f))
(home-page "https://mpv.io/")