summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-16 17:05:13 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-16 17:06:41 +0200
commit5f9a9945b5747e5ec284f8b116b2e8cc1b9064d7 (patch)
treeb2af47878515bee7f41b39483d8a9493527b8e8f /gnu/packages/video.scm
parentb64ce4b72564b45a422f4e7ffc30a5b95de91cff (diff)
gnu: vlc: Fix build with recent versions of libx264.
Fixes <https://bugs.gnu.org/32448>. Reported by Clément Lassieur <clement@lassieur.org>. * gnu/packages/video.scm (%vlc-libx264-compat.patch): New variable. (vlc)[source](patches): New field.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 6c10348c1d..8cd08efc72 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -850,6 +850,17 @@ thumbnailer uses ffmpeg to decode frames from the video files, so supported
videoformats depend on the configuration flags of ffmpeg.")
(license license:gpl2+)))
+;; Fix build with newer x264.
+(define %vlc-libx264-compat.patch
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://git.videolan.org/?p=vlc.git;a=patch;h="
+ "a8953ba707cca1f2de372ca24513296bcfcdaaa8"))
+ (file-name "vlc-libx264-compat.patch")
+ (sha256
+ (base32
+ "04igckbdp3sbp8vh0ihmhcf3yjyyk9r3cd5dm9mn9j6vipi1dg3g"))))
+
(define-public vlc
(package
(name "vlc")
@@ -860,6 +871,7 @@ videoformats depend on the configuration flags of ffmpeg.")
"https://download.videolan.org/pub/videolan/vlc/"
(car (string-split version #\-))
"/vlc-" version ".tar.xz"))
+ (patches (list %vlc-libx264-compat.patch))
(sha256
(base32
"1p7qvdvg9w4lz8vckzhn6bswfkq3qw7fqkgvwjcskdgc266xx7dw"))))