summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-06 09:55:00 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-06 09:55:00 +0200
commitd52ee267ee8245a6edfcd137c73d20b036ec08d1 (patch)
treee63d48c124949b2ecfba5993ade3399f91e4ca47 /gnu/packages/video.scm
parentbe46ab7a91ba8e53cd783db3e8d189c453df2c09 (diff)
gnu: streamlink: Update to 6.3.1.
* gnu/packages/video.scm (streamlink): Update to 6.3.1. [source]: Add snippet to accept older versions of python-trio. [native-inputs]: Remove python-mock. Add python-pytest-asyncio, python-pytest-trio. [propagated-inputs]: Add python-trio, python-trio-websocket, python-typing-websockets. Change-Id: Ib3e8930ed73974ddad4deb7015049b96c925b656
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm29
1 files changed, 21 insertions, 8 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 0dc89ed957..68581301a2 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -179,6 +179,7 @@
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
+ #:use-module (gnu packages python-check)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
@@ -3272,33 +3273,45 @@ and custom quantization matrices.")
(define-public streamlink
(package
(name "streamlink")
- (version "3.2.0")
+ (version "6.3.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "streamlink" version))
(sha256
(base32
- "09nrspga15svzi0hmakcarbciav0nzf30hg1ff53gia473cd4w4p"))))
+ "0i2qym2plm4gpcq50vl67j69m8a4zz9mb8gi2xryx28pbnpdzh4k"))
+ (snippet
+ #~(begin (use-modules (guix build utils))
+ (substitute* "pyproject.toml"
+ (("trio >=0\\.22") "trio >=0.21"))))))
(build-system python-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
+ `(#:phases
+ (modify-phases %standard-phases
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
(invoke "python" "-m" "pytest")))))))
(native-inputs
- (list python-freezegun python-mock python-pytest
- python-requests-mock))
+ (list python-freezegun
+ python-requests-mock
+ python-pytest
+ python-pytest-asyncio
+ python-pytest-trio))
(propagated-inputs
- (list python-pysocks
- python-websocket-client
+ (list python-certifi
python-isodate
python-lxml
python-pycountry
python-pycryptodome
+ python-pysocks
python-requests
- python-urllib3))
+ python-trio
+ python-trio-websocket
+ python-typing-extensions
+ python-urllib3
+ python-websocket-client))
(home-page "https://github.com/streamlink/streamlink")
(synopsis "Extract streams from various services")
(description "Streamlink is command-line utility that extracts streams