summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-18 10:34:21 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:10:53 -0400
commite7334321a53c21e11ee91b074916503c5798950c (patch)
tree24b26055a7dd49cd6403f77fd4555499316f7a77 /gnu/packages/video.scm
parent47234c396061d5bb80d9c4fa1e330f1a3875d8d7 (diff)
gnu: libx264: Update to 164-0.b093bbe.
* gnu/packages/video.scm (libx264): Update to 164-0.b093bbe. (libx264-next): Remove variable. * gnu/packages/jami.scm (ffmpeg-jami)[inputs]: Don't use LIBX264-NEXT.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm27
1 files changed, 3 insertions, 24 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index c3e0c28216..3d621bb603 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -915,8 +915,8 @@ shared library and encoder and decoder command-line executables.")
(define-public libx264
;; There are no tags in the repository, so we take the version number from
;; the X264_BUILD variable defined in x264.h.
- (let ((version "161")
- (commit "4c2aafd864dd201832ec2be0fef4484925146650")
+ (let ((version "164")
+ (commit "b093bbe7d9bc642c8f24067cbdcc73bb43562eab")
(revision "0"))
(package
(name "libx264")
@@ -929,7 +929,7 @@ shared library and encoder and decoder command-line executables.")
(file-name (git-file-name name version))
(sha256
(base32
- "1i6v9h3xx9pi0zmlj3anwwjxqa63sbhy9crrif8dphipwfn9hyg5"))))
+ "095pv8y6fqjg8mdvsfk12d0jqgyhip536a6vxhzm7qz8hfp96qhq"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config nasm))
@@ -979,27 +979,6 @@ H.264 (MPEG-4 AVC) video streams.")
"file://extras/cl.h"
"See extras/cl.h in the distribution."))))))
-;;; TODO: Merge into libx264 on staging.
-(define-public libx264-next
- ;; There are no tags in the repository, so we take the version number from
- ;; the X264_BUILD variable defined in x264.h.
- (let ((version "164")
- (commit "b093bbe7d9bc642c8f24067cbdcc73bb43562eab")
- (revision "0"))
- (package
- (inherit libx264)
- (name "libx264")
- (version (git-version version revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://code.videolan.org/videolan/x264.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "095pv8y6fqjg8mdvsfk12d0jqgyhip536a6vxhzm7qz8hfp96qhq")))))))
-
(define-public mkvtoolnix
(package
(name "mkvtoolnix")