summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-31 00:45:27 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-25 13:45:58 -0400
commitfafd3caef0d51811a5da81d6061789e2908b0dac (patch)
treeaf729a10642b490301d74a5dc984c614a9fe9de8 /gnu/packages/video.scm
parent713f959d49f813ae015c825ffdb9e55e4d270a70 (diff)
gnu: aalib: Really build the shared library on powerpc64le-linux.
Fixes <https://issues.guix.gnu.org/57134>. The old build scripts were buggy and causing a static library to be produced instead, which would fail to be linked by gst-plugins-good. * gnu/packages/video.scm (aalib) [native-inputs]: Remove labels. [arguments]: Use gexps. <configure-flags>: New argument. <phases>: Remove update-config-scripts and configure override. Add force-autoreconf. Reported-by: Marcel van der Boom <marcel@van-der-boom.nl> Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm43
1 files changed, 13 insertions, 30 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index c2f5b52042..5375424ce6 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -50,7 +50,7 @@
;;; Copyright © 2021 Alexey Abramov <levenson@mmer.org>
;;; Copyright © 2021, 2022, 2023 Andrew Tropin <andrew@trop.in>
;;; Copyright © 2021 David Wilson <david@daviwil.com>
-;;; Copyright © 2021,2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Thiago Jung Bauermann <bauermann@kolabnow.com>
@@ -741,36 +741,19 @@ stream decoding")
(base32
"1vkh19gb76agvh4h87ysbrgy82hrw88lnsvhynjf4vng629dmpgv"))))
(build-system gnu-build-system)
- (native-inputs
- `(("config" ,config)
- ("makeinfo" ,texinfo)))
- (inputs
- (list ncurses))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'update-config-scripts
- (lambda* (#:key inputs native-inputs #:allow-other-keys)
- ;; Replace outdated config.guess and config.sub.
- (for-each (lambda (file)
- (install-file
- (search-input-file
- (or native-inputs inputs)
- (string-append "/bin/" file)) "."))
- '("config.guess" "config.sub"))))
- (replace 'configure
- (lambda* (#:key build inputs outputs #:allow-other-keys)
- ;; This old `configure' script doesn't support
- ;; variables passed as arguments.
- (let ((out (assoc-ref outputs "out"))
- (ncurses (assoc-ref inputs "ncurses")))
- (setenv "CONFIG_SHELL" (which "bash"))
- (invoke "./configure"
- "--disable-static"
- (string-append "--prefix=" out)
- (string-append "--build=" build)
- (string-append "--with-ncurses="
- ncurses))))))))
+ (list
+ #:configure-flags
+ #~(list "--disable-static"
+ (string-append "--with-ncurses="
+ #$(this-package-input "ncurses")))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'force-autoreconf
+ (lambda _
+ (delete-file "configure"))))))
+ (native-inputs (list autoconf automake libtool texinfo))
+ (inputs (list ncurses))
(home-page "https://aa-project.sourceforge.net/aalib/")
(synopsis "ASCII-art library")
(description