summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-10-07 15:34:55 +0200
committerMarius Bakke <marius@gnu.org>2020-10-10 23:39:17 +0200
commit2f702f2d1fd4c962419c5286af980ca802193b58 (patch)
tree616aafa9221819a80e38fd60436b11c284dc22fa /gnu/packages/video.scm
parent210b5282b03a4e5d56c9181b8ac5632a45846549 (diff)
gnu: libvpx: Update to 1.9.0.
* gnu/packages/video.scm (libvpx): Update to 1.9.0.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 93508910aa..2ece217431 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2129,9 +2129,8 @@ To load this plugin, specify the following option when starting mpv:
(define-public libvpx
(package
(name "libvpx")
- (version "1.8.2")
+ (version "1.9.0")
(source (origin
- ;; XXX: Upstream does not provide tarballs for > 1.6.1.
(method git-fetch)
(uri (git-reference
(url "https://chromium.googlesource.com/webm/libvpx")
@@ -2139,7 +2138,7 @@ To load this plugin, specify the following option when starting mpv:
(file-name (git-file-name name version))
(sha256
(base32
- "0gyq4fkbd2fv7m1mm9xrvn6rk6f4jsmbv8bnlhingmnrvyncnmnr"))
+ "16xv6ambc82g14h1y0q1vyy57wp6j9fbp0nk0wd5csnrw407rhry"))
(patches (search-patches "libvpx-CVE-2016-2818.patch"))))
(build-system gnu-build-system)
(arguments
@@ -2157,7 +2156,11 @@ To load this plugin, specify the following option when starting mpv:
;; The configure script does not understand some of the GNU
;; options, so we only add the flags specified above.
(apply invoke "./configure" configure-flags))))
- #:tests? #f)) ; no check target
+
+ ;; XXX: The test suite wants to download 871 files from a cloud storage
+ ;; service (see test/test-data.sha1). It is possible to specify a
+ ;; custom directory, but there seems to be no tarball with all files.
+ #:tests? #f))
(native-inputs
`(("perl" ,perl)
("yasm" ,yasm)))