summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-15 21:12:22 -0400
committerLeo Famulari <leo@famulari.name>2016-10-15 21:17:17 -0400
commit31c580068ba1eda69f72ad1f672c8508e59cf7f4 (patch)
treed6b2404a3db78e860032c801235222bb4baf195a /gnu/packages/video.scm
parent57e57d433ad87221e871abbd6d16fa596ee05aec (diff)
gnu: youtube-dl: Disable the tests.
The tests were silently skipped with Python 3.4. With Python 3.5, this caused the youtube-dl build to fail. * gnu/packages/video.scm (youtube-dl)[arguments]: Disable tests.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 45c3233987..6d59ccc490 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -943,7 +943,8 @@ access to mpv's powerful playback capabilities.")
;; So, we need pass the prefix directly. In addition, make sure the Bash
;; completion file is called 'youtube-dl' rather than
;; 'youtube-dl.bash-completion'.
- `(#:phases (modify-phases %standard-phases
+ `(#:tests? #f ; Many tests fail. The test suite can be run with pytest.
+ #:phases (modify-phases %standard-phases
(add-before 'install 'fix-the-data-directories
(lambda* (#:key outputs #:allow-other-keys)
(let ((prefix (assoc-ref outputs "out")))