summaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundationdevices.com>2023-12-27 16:31:48 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-01-01 10:46:44 +0200
commitcb651129a3f061b619749d3e35fa0054ae40797d (patch)
treef0ea73077137afed9e22e2136e6252db25c24025 /gnu/packages/vim.scm
parentb34d0ceb85c4a286f4c982f987acb198dce3c8a3 (diff)
gnu: vim-coqtail: Move vim-full to arguments.
* gnu/packages/vim.scm (vim-coqtail)[arguments]: Set #:vim to use vim-full. Adjust custom 'check phase accordingly. [native-inputs]: Remove vim-full. Remove input labels. Change-Id: I20cc1e0772727f8fc7db70b42151432fb6349fc7 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 7fc6cae6e9..e27feb13f7 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -470,7 +470,8 @@ trouble using them, because you do not have to remember each snippet name.")
"0av2m075n6z05ah9ndrgnp9s16yrz6n2lj0igd9fh3c5k41x5xks"))))
(build-system vim-build-system)
(arguments
- '(#:plugin-name "coqtail"
+ `(#:plugin-name "coqtail"
+ #:vim ,vim-full ; Plugin needs Python 3.
#:phases
(modify-phases %standard-phases
(add-before 'install 'check
@@ -491,9 +492,7 @@ trouble using them, because you do not have to remember each snippet name.")
"/share/vim/vimfiles/pack/guix/start/vader")))
(with-directory-excursion "tests/vim"
(setenv "VADER_PATH" vader-path)
- (invoke (string-append
- (assoc-ref (or native-inputs inputs) "vim-full")
- "/bin/vim")
+ (invoke "vim"
"-E" "-Nu" "vimrc"
"-c" "Vader! *.vader")))
@@ -501,10 +500,9 @@ trouble using them, because you do not have to remember each snippet name.")
;; they don't get installed.
(delete-file-recursively "python/__pycache__")))))))
(native-inputs
- `(("coq-for-coqtail" ,coq-for-coqtail)
- ("python-pytest" ,python-pytest)
- ("vim-full" ,vim-full) ; Plugin needs Python 3.
- ("vim-vader" ,vim-vader)))
+ (list coq-for-coqtail
+ python-pytest
+ vim-vader))
(propagated-inputs (list coq coq-ide-server))
(synopsis "Interactive Coq proofs in Vim")
(description "Coqtail enables interactive Coq proof development in Vim