summaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-02-22 11:55:35 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-22 11:57:38 +0200
commitad839564c8bc31e91782375c494595478333a23e (patch)
tree30686175be72e72ff0533c7364fd784d6084e628 /gnu/packages/vim.scm
parent4cdf734804a90b26402f7fd048a272bb8858fc8f (diff)
gnu: vim-dispatch: Update to 1.8-1.4c695bc.
* gnu/packages/vim.scm (vim-dispatch): Update to 1.8-1.4c695bc. Change-Id: I70b53f048c365fda47ba8820392b1f94b6bcfedd
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm43
1 files changed, 23 insertions, 20 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 6b0680fcbe..fe12768159 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1080,29 +1080,32 @@ quickfix window in realtime.")
(name "neovim-asyncrun")))
(define-public vim-dispatch
- (package
- (name "vim-dispatch")
- (version "1.8")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tpope/vim-dispatch")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1m8b5mn2zqlphzs6xfwykwmghf6p0wabrhpjmh7vav35jgcxc4wl"))))
- (build-system vim-build-system)
- (arguments
- (list #:plugin-name "dispatch"))
- (home-page "https://github.com/tpope/vim-dispatch")
- (synopsis "Asynchronous build and test dispatcher")
- (description "Leverage the power of Vim's compiler plugins without being
+ ;; Last release was in June 2019.
+ (let ((commit "4c695bc052cad2ae6b980aebbe48d046466e27ae")
+ (revision "1"))
+ (package
+ (name "vim-dispatch")
+ (version (git-version "1.8" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tpope/vim-dispatch")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13c63n7gylny2s84k05cpl4cjn070d3qk6yagxny23yanz29hc15"))))
+ (build-system vim-build-system)
+ (arguments
+ (list #:plugin-name "dispatch"))
+ (home-page "https://github.com/tpope/vim-dispatch")
+ (synopsis "Asynchronous build and test dispatcher")
+ (description "Leverage the power of Vim's compiler plugins without being
bound by synchronicity. Kick off builds and test suites using one of several
asynchronous adapters (including tmux, screen, and a headless mode), and when
the job completes, errors will be loaded and parsed automatically.")
- (license license:vim)))
+ (license license:vim))))
(define-public vim-gemini-vim
;; No releases have been tagged.