summaryrefslogtreecommitdiff
path: root/gnu/packages/vulkan.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2023-12-30 13:31:36 +0800
committerMathieu Othacehe <othacehe@gnu.org>2024-01-03 15:32:01 +0100
commit80f6e5a9ea87bb6665d6323c5a73ad5e929409fa (patch)
treed21169381b1b37603055b0d9b67a8705af438b9e /gnu/packages/vulkan.scm
parente2ad70c951c0c8a79883fe232afa0ae88a6f1d84 (diff)
gnu: vulkan-loader: Fix cross-compiling.
gnu/packages/vulkan.scm(vulkan-loader): [arguments]<#:configure-flags>: When cross-compiling, set -DBUILD_TESTS=OFF and -DUSE_GAS=OFF. [inputs]: Add libxrandr. Change-Id: I580e1c77c4b9b5a3483e93ff9eda78fbe07ec292
Diffstat (limited to 'gnu/packages/vulkan.scm')
-rw-r--r--gnu/packages/vulkan.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index ca771a30b1..285d6be7f5 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
;;; Copyright © 2022 Kaelyn Takata <kaelyn.alexi@protonmail.com>
;;; Copyright © 2022 dan <i@dan.games>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -270,7 +271,9 @@ interpretation of the specifications for these languages.")
(dirname (dirname
(search-input-directory
%build-inputs "include/vulkan"))))
- "-DBUILD_TESTS=ON")
+ #$@(if (%current-target-system)
+ #~("-DBUILD_TESTS=OFF" "-DUSE_GAS=OFF")
+ #~("-DBUILD_TESTS=ON")))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'fix-pkg-config-file
@@ -299,7 +302,7 @@ interpretation of the specifications for these languages.")
python
wayland))
(inputs
- (list vulkan-headers))
+ (list vulkan-headers libxrandr))
(home-page
"https://github.com/KhronosGroup/Vulkan-Loader")
(synopsis "Khronos official ICD loader and validation layers for Vulkan")