summaryrefslogtreecommitdiff
path: root/gnu/packages/vulkan.scm
diff options
context:
space:
mode:
authordan <i@dan.games>2022-11-20 21:49:31 +0800
committerMarius Bakke <marius@gnu.org>2022-11-20 17:20:00 +0100
commitcae97cd773befcc68ce0ba8709e50c8697b7f0d3 (patch)
tree97c074dd65efa8b3d0055b43b0eab6f68cddb422 /gnu/packages/vulkan.scm
parentb758242df811cc657231bd10ec5cdad8421df092 (diff)
gnu: Add vulkan-memory-allocator.
* gnu/packages/vulkan.scm (vulkan-memory-allocator): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/vulkan.scm')
-rw-r--r--gnu/packages/vulkan.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 95b8542133..6f58866627 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
;;; Copyright © 2022 Kaelyn Takata <kaelyn.alexi@protonmail.com>
+;;; Copyright © 2022 dan <i@dan.games>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -502,3 +503,32 @@ entrypoints directly from the driver which can increase performance by
skipping loader dispatch overhead.")
(home-page "https://github.com/zeux/volk")
(license license:expat)))
+
+(define-public vulkan-memory-allocator
+ (package
+ (name "vulkan-memory-allocator")
+ (version "3.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hpzjwl5bgqv9hmf1fdldihfllcbdg515f391a200klg0rnixdds"))))
+ (build-system cmake-build-system)
+ (arguments
+ ;; no test
+ `(#:tests? #f))
+ (inputs (list vulkan-loader vulkan-headers))
+ (synopsis "Vulkan memory allocation library")
+ (description
+ "The Vulkan Memory Allocator (VMA) library provides a simple and easy to
+integrate API to help users allocate memory for Vulkan buffer and image
+storage.")
+ (home-page
+ "https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator")
+ (license license:expat)))