summaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
commit8c3e9da13a3c92a7db308db8c0d81cb474ad7799 (patch)
tree88d06952aa5cc3a9c4991d9c43eb7950ff174fe1 /gnu/packages/web-browsers.scm
parent5439c04ebdb7b6405f5ea2446b375f1d155a8d95 (diff)
parent0c5299200ffcd16370f047b7ccb187c60f30da34 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm98
1 files changed, 59 insertions, 39 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index bae161806b..ad03c4fa53 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -159,41 +159,44 @@ management, extensions such as advertisement blocker and colorful tabs.")
(define-public links
(package
(name "links")
- (version "2.25")
+ (version "2.27")
(source (origin
(method url-fetch)
(uri (string-append "http://links.twibright.com/download/"
"links-" version ".tar.bz2"))
(sha256
(base32
- "0b6x97xi8i4pag2scba02c0h95cm3sia58q99zppk0lfd448bmrd"))))
+ "1d7bz6bbis94jq82xydwnazaczzmb1ij62pbmf0dxkg7xpycppfq"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- ;; The tarball uses a very old version of autoconf. It doesn't
- ;; understand extra flags like `--enable-fast-install', so
- ;; we need to invoke it with just what it understands.
- (let ((out (assoc-ref outputs "out")))
- ;; 'configure' doesn't understand '--host'.
- ,@(if (%current-target-system)
- `((setenv "CHOST" ,(%current-target-system)))
- '())
- (setenv "CONFIG_SHELL" (which "bash"))
- (invoke "./configure"
- (string-append "--prefix=" out)
- "--enable-graphics")))))))
+ (list
+ #:configure-flags #~(list "--enable-graphics")
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs (configure-flags '()) #:allow-other-keys)
+ ;; The tarball uses a very old version of autoconf. It doesn't
+ ;; understand extra flags like `--enable-fast-install', so
+ ;; we need to invoke it with just what it understands.
+ (let ((out (assoc-ref outputs "out")))
+ ;; 'configure' doesn't understand '--host'.
+ #$@(if (%current-target-system)
+ #~((setenv "CHOST" #$(%current-target-system)))
+ #~())
+ (setenv "CONFIG_SHELL" (which "bash"))
+ (apply invoke "./configure"
+ (string-append "--prefix=" out)
+ configure-flags)))))))
(native-inputs (list pkg-config))
- (inputs `(("gpm" ,gpm)
- ("libevent" ,libevent)
- ("libjpeg" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("libtiff" ,libtiff)
- ("libxt" ,libxt)
- ("openssl" ,openssl)
- ("zlib" ,zlib)))
+ (inputs
+ (list gpm
+ libevent
+ libjpeg-turbo
+ libpng
+ libtiff
+ libxt
+ openssl
+ zlib))
(synopsis "Text and graphics mode web browser")
(description "Links is a graphics and text mode web browser, with many
features including, tables, builtin image display, bookmarks, SSL and more.")
@@ -465,7 +468,7 @@ interface.")
(define-public qutebrowser
(package
(name "qutebrowser")
- (version "2.4.0")
+ (version "2.5.1")
(source
(origin
(method url-fetch)
@@ -473,14 +476,13 @@ interface.")
"qutebrowser/releases/download/v" version "/"
"qutebrowser-" version ".tar.gz"))
(sha256
- (base32 "1v4jhlmgfm8v9sbf7i3xg1vjh6dy8y2gpckk0mizkazb2jxrmkgj"))))
+ (base32 "1g7dfrnjgifvbmz1523iq9qxhrsciajr8dv3pak6dlacm235i276"))))
(build-system python-build-system)
(native-inputs
(list python-attrs)) ; for tests
(inputs
(list bash-minimal
python-colorama
- python-cssutils
python-jinja2
python-markupsafe
python-pygments
@@ -506,16 +508,33 @@ interface.")
(let ((out (assoc-ref outputs "out")))
(substitute* "qutebrowser/utils/standarddir.py"
(("/usr/share") (string-append out "/share"))))))
+ (add-after 'unpack 'find-userscripts
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "qutebrowser/commands/userscripts.py"
+ (("os.path.join.*system=True)")
+ (string-append "os.path.join(\""
+ (assoc-ref outputs "out")
+ "\", \"share\", \"qutebrowser\"")))))
(add-before 'check 'set-env-offscreen
(lambda _
(setenv "QT_QPA_PLATFORM" "offscreen")))
(add-after 'install 'install-more
(lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (rename-file "misc/Makefile" "Makefile")
+ (substitute* "Makefile"
+ ((".*setup\\.py.*") ""))
+ (invoke "make" "install" (string-append "PREFIX=" out))
+ (delete-file-recursively (string-append out "/share/metainfo")))))
+ (add-after 'install-more 'wrap-scripts
+ (lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (app (string-append out "/share/applications"))
- (hicolor (string-append out "/share/icons/hicolor")))
- (install-file "doc/qutebrowser.1"
- (string-append out "/share/man/man1"))
+ (python (assoc-ref inputs "python"))
+ (path (string-append out "/lib/python"
+ ,(version-major+minor (package-version
+ python))
+ "/site-packages:"
+ (getenv "GUIX_PYTHONPATH"))))
(for-each
(lambda (i)
(let ((src (format #f "icons/qutebrowser-~dx~d.png" i i))
@@ -706,7 +725,7 @@ is fully configurable and extensible in Common Lisp.")
(define-public lagrange
(package
(name "lagrange")
- (version "1.11.2")
+ (version "1.13.6")
(source
(origin
(method url-fetch)
@@ -714,13 +733,14 @@ is fully configurable and extensible in Common Lisp.")
(string-append "https://git.skyjake.fi/skyjake/lagrange/releases/"
"download/v" version "/lagrange-" version ".tar.gz"))
(sha256
- (base32 "07vr0n8zpxcf6vjf4rz30s75llzxg9yndqphar4b1iygig9rx6jf"))
+ (base32 "19xaw6lspl4mjx1wls0s15l97dzfkv20gph652yzwk6ia3ly92bs"))
(modules '((guix build utils)))
(snippet
'(begin
;; TODO: unbundle fonts.
(delete-file-recursively "lib/fribidi")
- (delete-file-recursively "lib/harfbuzz")))))
+ (delete-file-recursively "lib/harfbuzz")
+ (delete-file-recursively "lib/sealcurses")))))
(build-system cmake-build-system)
(arguments
`(#:tests? #false ;no tests
@@ -922,14 +942,14 @@ interface.")
(define-public telescope
(package
(name "telescope")
- (version "0.7.1")
+ (version "0.8.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/omar-polo/telescope/releases/download/"
version "/telescope-" version ".tar.gz"))
(sha256
- (base32 "055iqld99l4jshs10mhl2ml0p74wcyyv5kxjy8izzysw9lnkjjb5"))))
+ (base32 "1fblm3mjddhjmcj1c065n9440n72ld037bdjdlyk1fpwd240m1pa"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f)) ;no tests
@@ -937,7 +957,7 @@ interface.")
(list gettext-minimal pkg-config))
(inputs
(list libevent libressl ncurses))
- (home-page "https://git.omarpolo.com/telescope/about/")
+ (home-page "https://telescope.omarpolo.com/")
(synopsis "Gemini client with a terminal interface")
(description "Telescope is a w3m-like browser for Gemini.")
(license license:x11)))