summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2023-01-01 20:46:06 +0000
committerLudovic Courtès <ludo@gnu.org>2023-01-10 11:49:14 +0100
commit0c0dc72ac00ac0e2cb7abd6f46e37df3a1af1c62 (patch)
tree5adc29da62d3b59106b548ca08447657991c062f /gnu/packages/web.scm
parent5f63811032dab5c04c397e043cc7290cb3d51ee0 (diff)
gnu: Add vger.
* gnu/packages/web.scm (vger): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index f31a573e22..619030c120 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -59,6 +59,7 @@
;;; Copyright © 2022 Pradana Aumars <paumars@courrier.dev>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2023 Paul A. Patience <paul@apatience.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -147,6 +148,7 @@
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages kde)
#:use-module (gnu packages kerberos)
+ #:use-module (gnu packages libbsd)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libidn)
#:use-module (gnu packages libunistring)
@@ -8064,6 +8066,48 @@ concurrency, and return status.")
(license (list license:gpl3+
license:bsd-3)))) ;; for ini.c and ini.h
+(define-public vger
+ (package
+ (name "vger")
+ (version "2.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://tildegit.org/solene/vger")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jiwzn5dqadwq4ih3vzld66yq23gqsf7281sllh29bf6kmf9dz2k"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:test-target "test"
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-makefile
+ (lambda _
+ (substitute* "Makefile"
+ (("\\binstall -o root -g wheel vger ")
+ "install vger ")
+ (("\\binstall -o root -g wheel vger\\.8 ")
+ "install -m 644 vger.8 "))))
+ (add-before 'install 'make-install-dirs
+ (lambda _
+ (mkdir-p (string-append #$output "/bin"))
+ (mkdir-p (string-append #$output "/man/man8")))))))
+ (inputs
+ (list libbsd))
+ (home-page "https://tildegit.org/solene/vger")
+ (synopsis "Gemini protocol server")
+ (description "Vger is a Gemini protocol server that supports chroots,
+virtualhosts, CGI, default language choice, redirections and MIME-type
+detection. It delegates TLS support to an external daemon, for example
+@command{stunnel} on @command{inetd}.")
+ (license license:bsd-2)))
+
(define-public libzim
(package
(name "libzim")