summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-09-08 23:12:28 +0800
committerMarius Bakke <marius@gnu.org>2023-09-22 01:29:19 +0800
commitc7cb52e3fa65f7f163e244c11036f0898fd01058 (patch)
tree827a6cb3d7f4b4f90cd0218fc5a4e839e70bb1d7 /gnu/packages/web.scm
parent687ae1f8d1d39e1e2fbe2ca7aecfaf3f6e14267a (diff)
gnu: websockify: Update to 0.11.0.
* gnu/packages/web.scm (websockify): Update to 0.11.0. [build-system]: Switch to PYPROJECT-BUILD-SYSTEM. [arguments]: Remove. [native-inputs]: Remove PYTHON-MOX3. [propagated-inputs]: Add PYTHON-JWCRYPTO, PYTHON-REDIS, PYTHON-REQUESTS, and PYTHON-SIMPLEJSON.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 631106028d..e850531a8e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1985,7 +1985,7 @@ of people.")
(define-public websockify
(package
(name "websockify")
- (version "0.8.0")
+ (version "0.11.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1994,15 +1994,16 @@ of people.")
(file-name (git-file-name name version))
(sha256
(base32
- "0pcic8qs0gdwrfjgfaf893jyddaw97wcjm2mmvwn0xyhmy8mbmw1"))))
- (build-system python-build-system)
- (arguments
- `(#:tests? #f)) ; FIXME: 2 out of 6 tests fail with "ImportError: No module
- ; named 'stubout'". The tests can be run by replacing the check phase with
- ; the command "python setup.py nosetests --verbosity=3".
- (native-inputs (list ; Required for tests:
- python-mox3 python-nose))
- (propagated-inputs (list python-numpy))
+ "0ysqylpyv17s52634wn3vrwf7y9b5ig7fdfv8vwj1272lvv68qgk"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-nose2))
+ (propagated-inputs
+ (list python-jwcrypto
+ python-numpy
+ python-redis
+ python-requests
+ ;; TODO: Remove simplejson for versions > 0.11.0.
+ python-simplejson))
(home-page "https://github.com/novnc/websockify")
(synopsis "WebSockets support for any application/server")
(description "Websockify translates WebSockets traffic to normal socket