summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-03-18 09:50:56 +0100
committerLars-Dominik Braun <lars@6xq.net>2023-03-18 09:50:56 +0100
commitf9bff8614be32f9c2c1a54da80eaed1365b49be3 (patch)
treefe60e095d333a3d4616ef18b6e64ec08d85c666e /gnu/packages/web.scm
parentcfccd6fe5ae00d7e81cd755be55d51ff3bf17186 (diff)
gnu: python-feedparser: Add Python >=3.9 compatibility.
* gnu/packages/patches/python-feedparser-missing-import.patch: New file. * gnu/local.mk: Add it. * gnu/packages/web.scm (python-feedparser): Use it.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 6e79fe99b8..9f45d24716 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4750,7 +4750,8 @@ their web site.")
(method url-fetch)
(uri (pypi-uri "feedparser" version ".tar.gz"))
(sha256
- (base32 "0lfa1c8s6abnlksbwxdpq78bg4rb6603mcgarmip3kip8rglini7"))))
+ (base32 "0lfa1c8s6abnlksbwxdpq78bg4rb6603mcgarmip3kip8rglini7"))
+ (patches (search-patches "python-feedparser-missing-import.patch"))))
(build-system python-build-system)
(propagated-inputs
(list python-sgmllib3k))