summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-02-06 21:14:11 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-02-07 18:48:53 -0500
commit18cb3df83718afe1253481b42b4707771d99f0f0 (patch)
tree64e1ef524b37e417a5b6595856234772bc41c9d6 /gnu/packages/web.scm
parent0cb804117f93b72d18f3802bcfd7788722a5fb9b (diff)
gnu: Add tidy.
* gnu/packages/web.scm (tidy): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 25747526f8..0e3bf14d0d 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -27,6 +27,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix cvs-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
#:use-module (guix build-system cmake)
@@ -288,6 +289,41 @@ domains (UTF-8 and IDNA2008 Punycode), is thread-safe, and handles IDNA2008
UTS#46")
(license l:x11)))
+(define-public tidy
+ (package
+ (name "tidy")
+ (version "20091223")
+ (source (origin
+ (method cvs-fetch)
+ (uri (cvs-reference
+ (root-directory
+ ":pserver:anonymous@tidy.cvs.sourceforge.net:/cvsroot/tidy")
+ (module "tidy")
+ (revision "2009-12-23")))
+ (sha256
+ (base32
+ "14dsnmirjcrvwsffqp3as70qr6bbfaig2fv3zvs5g7005jrsbvpb"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (alist-cons-before
+ 'configure 'bootstrap
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; configure.in and Makefile.am aren't in the root of the
+ ;; source tree.
+ (copy-recursively "build/gnuauto" ".")
+ (setenv "AUTOMAKE" "automake --foreign")
+ (zero? (system* "autoreconf" "-vfi")))
+ %standard-phases)))
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoconf" ,autoconf)
+ ("libtool" ,libtool)))
+ (synopsis "HTML validator and tidier")
+ (description "HTML Tidy is a command-line tool and C library that can be
+used to validate and fix HTML data.")
+ (home-page "http://tidy.sourceforge.net/")
+ (license (l:x11-style "file:///include/tidy.h"))))
+
(define-public perl-html-tagset
(package
(name "perl-html-tagset")