summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-12-08 21:53:12 +0100
committerAndreas Enge <andreas@enge.fr>2013-12-08 21:53:12 +0100
commit3f41e6b31008ba5c3ce09aac559f62e768d6c612 (patch)
tree2eb2269dc4dcc6152d10ee1fd5c788918594f6b5 /gnu/packages/web.scm
parentb3d18aff2fe0697acbdc5afd14358f435969106d (diff)
gnu: Add perl-http-daemon.
* gnu/packages/web.scm (perl-http-daemon): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index f1db4ebc04..3615559768 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -242,3 +242,29 @@ algorithm specified in section 8.2.2.1 of the draft standard.")
that is, a database of all the HTTP cookies that a given LWP::UserAgent
object knows about.")
(home-page "http://search.cpan.org/~gaas/HTTP-Cookies/")))
+
+(define-public perl-http-daemon
+ (package
+ (name "perl-http-daemon")
+ (version "6.01")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/G/GA/GAAS/HTTP-Daemon-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1hmd2isrkilf0q0nkxms1q64kikjmcw9imbvrjgky6kh89vqdza3"))))
+ (build-system perl-build-system)
+ (inputs
+ `(("perl-http-date" ,perl-http-date)
+ ("perl-http-message" ,perl-http-message)
+ ("perl-lwp-mediatypes" ,perl-lwp-mediatypes)
+ ("perl-uri" ,perl-uri)))
+ (license (package-license perl))
+ (synopsis "Perl simple http server class")
+ (description
+ "Instances of the HTTP::Daemon class are HTTP/1.1 servers that listen
+on a socket for incoming requests. The HTTP::Daemon is a subclass of
+IO::Socket::INET, so you can perform socket operations directly on it too.")
+ (home-page "http://search.cpan.org/~gaas/HTTP-Daemon/")))