summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-10-11 20:41:41 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-10-14 23:41:26 +0300
commit4b0e08beb2620336910197738df8ce1e36abda33 (patch)
tree84c24102e977db611f997e93caa7ddefb3f4d94e /gnu/packages/web.scm
parent89c4122ec9b816e5d6902c3b17e912543fd21033 (diff)
gnu: Add nginx-socket-cloexec.
* gnu/packages/patches/nginx-socket-cloexec.patch: New file. * gnu/local.mk (dist_patch_DATA): Add this. * gnu/packages/web.scm (nginx-socket-cloexec): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index f291768e12..0c0e159f98 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -551,6 +551,16 @@ This is modified version, specifically intended for use with the NGinx
documentation.")
(license license:bsd-2))))
+(define nginx-socket-cloexec
+ (package
+ (inherit nginx)
+ (name "nginx-socket-cloexec") ;required for lua-resty-shell
+ (source
+ (origin
+ (inherit (package-source nginx))
+ (patches (append (search-patches "nginx-socket-cloexec.patch")
+ (origin-patches (package-source nginx))))))))
+
(define-public lighttpd
(package
(name "lighttpd")