summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-04-01 07:42:27 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-05-31 04:54:53 +0200
commit7f4e5f19fa6f8c2ef325f51690da37eab402872e (patch)
tree6da6f51f46ab97d00fdeb012ab951ec60dada081 /gnu/packages/web.scm
parentb5d587055b5496564f7492ff7ba3a6ea6a7b7b02 (diff)
gnu: sassc: Use INVOKE.
* gnu/packages/web.scm (sassc)[arguments]: Substitute INVOKE for SYSTEM* and its plumbing.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index e79001cb78..ace7027847 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1236,11 +1236,9 @@ minimum to provide high performance operation.")
(delete 'configure)
(add-after 'unpack 'unpack-libsass-and-set-path
(lambda* (#:key inputs #:allow-other-keys)
- (and (zero? (system* "tar" "xvf" (assoc-ref inputs "libsass")))
- (begin
- (setenv "SASS_LIBSASS_PATH"
- (string-append (getcwd) "/libsass-" ,version))
- #t)))))))
+ (invoke "tar" "xvf" (assoc-ref inputs "libsass"))
+ (setenv "SASS_LIBSASS_PATH"
+ (string-append (getcwd) "/libsass-" ,version)))))))
(inputs
`(("libsass" ,libsass)))
(synopsis "CSS pre-processor")