summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-11 23:30:32 +0200
committerMarius Bakke <marius@gnu.org>2020-06-11 23:30:32 +0200
commit9b043df7403a10b35b93d133aac796fd277a7339 (patch)
treef712922d9348ececc0d84e360ac653df3b8d2473 /gnu/packages/web.scm
parentd79ec4fd343bc2a72652aa3a4b4ae14bd8df88ac (diff)
parent648ae62112f62bc2106fb36d45c83fda787d3bed (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 366c593865..26396fd59d 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1588,7 +1588,7 @@ from streaming URLs. It is a command-line wrapper for the libquvi library.")
(source
(origin
(method url-fetch)
- (uri (string-append "https://archive.apache.org/dist/serf/serf-"
+ (uri (string-append "mirror://apache/dist/serf/serf-"
version ".tar.bz2"))
(sha256
(base32 "1k47gbgpp52049andr28y28nbwh9m36bbb0g8p0aka3pqlhjv72l"))))
@@ -7206,6 +7206,7 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
(package
(name "nghttp2")
(version "1.40.0")
+ (replacement nghttp2-1.41)
(source
(origin
(method url-fetch)
@@ -7285,6 +7286,20 @@ compressed JSON header blocks.
@end itemize\n")
(license license:expat)))
+(define-public nghttp2-1.41 ;fixes CVE-2020-11080
+ (package
+ (inherit nghttp2)
+ (version "1.41.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/nghttp2/nghttp2/"
+ "releases/download/v" version "/"
+ "nghttp2-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1hk77vngjmvvzb5y1gi1aqwf6qywrc7yak08zvzb7x81qs6mphmb"))))))
+
(define-public hpcguix-web
(let ((commit "9de63562b06b4aef3a3afe5ecb18d3c91e57ee74")
(revision "5"))