summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-14 22:54:27 +0200
committerMarius Bakke <marius@gnu.org>2020-05-26 22:32:55 +0200
commitbeec29da921345c2e46852c531161fb5ddd3076f (patch)
tree502749990bfea9865cdd8880dabff2dc69d87b76 /gnu/packages/web.scm
parentf2ff01bb8e794ead5d31548505c840caf6a9aa39 (diff)
gnu: json-c: Update to 0.14.
* gnu/packages/web.scm (json-c): Update to 0.14. [source](modules, snippet): Remove. [build-system]: Change to CMAKE-BUILD-SYSTEM. (json-c-0.13): New public variable. (json-c-0.12): Inherit from JSON-C-0.13. * gnu/packages/cryptsetup.scm (cryptsetup-static)[inputs]: Stick with JSON-C-0.13. * gnu/packages/linux.scm (multipath-tools)[inputs]: Likewise. * gnu/packages/security-token.scm (yubikey-personalization, libu2f-host, libu2f-server)[inputs]: Likewise. * gnu/packages/syndication.scm (newsboat)[inputs]: Likewise.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm39
1 files changed, 26 insertions, 13 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index eabc3c0197..1ccab7777b 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -768,7 +768,7 @@ data.")
(define-public json-c
(package
(name "json-c")
- (version "0.13.1")
+ (version "0.14")
(source (origin
(method url-fetch)
(uri (string-append
@@ -776,7 +776,29 @@ data.")
version ".tar.gz"))
(sha256
(base32
- "0ws8dz9nk8q2c0gbf66kg2r6mrkl7kamd3gpdv9zsyrz9n6n0zmq"))
+ "0w381krr99q5a2rypx4g437fa7gzgl82i64sgnrs6g5jr44dwxxk"))))
+ (build-system cmake-build-system)
+ (home-page "https://github.com/json-c/json-c/wiki")
+ (synopsis "JSON implementation in C")
+ (description
+ "JSON-C implements a reference counting object model that allows you to
+easily construct JSON objects in C, output them as JSON-formatted strings and
+parse JSON-formatted strings back into the C representation of JSON objects.
+It aims to conform to RFC 7159.")
+ (license license:x11)))
+
+;; TODO: Remove these old versions when all dependents have been updated.
+(define-public json-c-0.13
+ (package
+ (inherit json-c)
+ (version "0.13.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://s3.amazonaws.com/json-c_releases/releases/json-c-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0ws8dz9nk8q2c0gbf66kg2r6mrkl7kamd3gpdv9zsyrz9n6n0zmq"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -786,20 +808,11 @@ data.")
(set-file-time "config.h.in"
(stat "aclocal.m4"))
#t))))
- (build-system gnu-build-system)
- (home-page "https://github.com/json-c/json-c/wiki")
- (synopsis "JSON implementation in C")
- (description
- "JSON-C implements a reference counting object model that allows you to
-easily construct JSON objects in C, output them as JSON-formatted strings and
-parse JSON-formatted strings back into the C representation of JSON objects.
-It aims to conform to RFC 7159.")
- (license license:x11)))
+ (build-system gnu-build-system)))
-;; TODO: remove this old version when all dependents have been updated.
(define-public json-c-0.12
(package
- (inherit json-c)
+ (inherit json-c-0.13)
(version "0.12.1")
(source (origin
(method url-fetch)