summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-01-04 21:21:04 -0500
committerMark H Weaver <mhw@netris.org>2018-01-04 21:21:04 -0500
commit247d23680a222bc5440dec7c3fe0d36ad463a121 (patch)
tree4e3c28a2e7b0531c7883ae1c40348f1533a20c4e /gnu/packages/web.scm
parente21ce0f9040592d398668498119565d94a639a04 (diff)
parent72687ca5d2d8d1dd55b152823a164606fa421d9c (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm45
1 files changed, 39 insertions, 6 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index aef54982db..10757cb546 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2016, 2017 ng0 <ng0@infotropique.org>
;;; Copyright © 2016, 2017 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2016, 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Bake Timmons <b3timmons@speedymail.org>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
@@ -514,7 +514,7 @@ data.")
(define-public json-c
(package
(name "json-c")
- (version "0.12.1")
+ (version "0.13")
(source (origin
(method url-fetch)
(uri (string-append
@@ -522,7 +522,7 @@ data.")
version ".tar.gz"))
(sha256
(base32
- "08qibrq29a5v7g23wi5icy6l4fbfw90h9ccps6vq0bcklx8n84ra"))
+ "0kf2594kxcfga6x0mvwzj2qg8pgxhjkibc16ghnw85mdx45ph5h3"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -542,10 +542,36 @@ data.")
(synopsis "JSON implementation in C")
(description
"JSON-C implements a reference counting object model that allows you to
-easily construct JSON objects in C, output them as JSON formatted strings and
-parse JSON formatted strings back into the C representation of JSON objects.")
+easily construct JSON objects in C, output them as JSON-formatted strings and
+parse JSON-formatted strings back into the C representation of JSON objects.
+It aims to conform to RFC 7159.")
(license l:x11)))
+;; TODO: remove this old version when all dependents have been updated.
+(define-public json-c-0.12
+ (package
+ (inherit json-c)
+ (version "0.12.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://s3.amazonaws.com/json-c_releases/releases/json-c-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "08qibrq29a5v7g23wi5icy6l4fbfw90h9ccps6vq0bcklx8n84ra"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Somehow 'config.h.in' is older than
+ ;; 'aclocal.m4', which would trigger a rule to
+ ;; run 'autoheader'.
+ (set-file-time "config.h.in"
+ (stat "aclocal.m4"))
+
+ ;; Don't try to build with -Werror.
+ (substitute* (find-files "." "Makefile\\.in")
+ (("-Werror") ""))))))))
+
(define-public qjson
(package
(name "qjson")
@@ -4279,7 +4305,7 @@ C. It is developed as part of the NetSurf project.")
`(("netsurf-buildsystem" ,netsurf-buildsystem)
("pkg-config" ,pkg-config)
("doxygen" ,doxygen)
- ("json-c" ,json-c)
+ ("json-c" ,json-c-0.12) ; check whether json-c-0.12 can be removed
("perl" ,perl)))
(propagated-inputs
`(("libparserutils" ,libparserutils))) ;for libhubbub.pc
@@ -4739,6 +4765,13 @@ handling many of the web standards in use today.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-before 'configure 'patch-perl
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((perl (assoc-ref inputs "perl")))
+ (substitute* "surfraw.IN"
+ (("perl -e")
+ (string-append perl "/bin/perl -e")))
+ #t)))
(add-after 'install 'compress-elvi.1sr
(lambda* (#:key outputs #:allow-other-keys)
;; The manpages of the elvis are symlinks to elvi.1sr.gz